Mautic Community Forums

SELF HOSTED | FIELDS | { command not working

Hello everyone,



I have been attempting to move a fairly elaborate marketing campaign to Mautic and I’ve run into some hurdles I’m not sure how to overcome.



I would like each contact’s first name to appear in each email sent. Eg, “Hi FIRSTNAME”. However, when attempting to add the field into an email nothing comes up when I press the { key as per this tutorial : https://www.mautic.org/blog/tip-of-the-week-insert-fields/



Please would someone be so kind as to point me in the right direction to get this working? I have experimented with these combinations to “call” the field value into the email:



{infield-firstname}

{infield=firstname}

{firstname}



On another note, I have also noticed that I am unable to enable the " Is Unique Identifier?" option under the “Edit Custom Field” page as it is blurred out

Quote:
. Is this required for the fields to work in emails? Why is this blurred out?

Here is an image of the greyed out button:
2015-09-09_1659.png

Thank you for any assistance!

Hello everyone,

I have been attempting to move a fairly elaborate marketing campaign to Mautic and I’ve run into some hurdles I’m not sure how to overcome.

I would like each contact’s first name to appear in each email sent. Eg, “Hi FIRSTNAME”. However, when attempting to add the field into an email nothing comes up when I press the { key as per this tutorial : https://www.mautic.org/blog/tip-of-the-week-insert-fields/

Please would someone be so kind as to point me in the right direction to get this working? I have experimented with these combinations to “call” the field value into the email:

{infield-firstname}
{infield=firstname}
{firstname}

On another note, I have also noticed that I am unable to enable the " Is Unique Identifier?" option under the “Edit Custom Field” page as it is blurred out[quote][/quote]. Is this required for the fields to work in emails? Why is this blurred out?

Here is an image of the greyed out button:

Thank you for any assistance!

Try {leadfield=firstname}

The drop-down should appear when you type {le

Not sure about the “Is Unique Identifier” problem – it works for me (but I’m also not sure when one would use it…)

I have the same problem, “Is Unique Identifier” is blurred out. I need to enable it for “Phone” field. How can I enable it?

Hi escopecz,

This doesn’t seem to work for me at all.

Please see video here of me trying :
Edit, fixed video: http://screencast.com/t/ReQVAt9WXSXk

Works for me:

Try to type “{lead” without hitting backspace in the process. It’s quite sensitive. If that doesn’t help, open the browser dev tools (press F12), navigate to Console tab and let us know if you see some javascript error. Also, describe what OS and browser do you use.

[quote=3947:@escopecz]Works for me:

Try to type “{lead” without hitting backspace in the process. It’s quite sensitive. If that doesn’t help, open the browser dev tools (press F12), navigate to Console tab and let us know if you see some javascript error. Also, describe what OS and browser do you use.[/quote]

Thanks for this reply.

It works, it seems as though it is a host speed problem. Entering in {lead results in the expected behaviour but only after around 10 seconds or so of “load” time.

[quote=2979:@derrickm]Try {leadfield=firstname}

The drop-down should appear when you type {le

Not sure about the “Is Unique Identifier” problem – it works for me (but I’m also not sure when one would use it…)[/quote]

Thanks for this. The {leadfield=firstname} works when defined in multiple locations.

Does the {e autocomplete/suggest only work in the email builder?

@andrewchildsza The autocomplete works in the email HTML area without using the Email Builder as well. Read https://www.mautic.org/blog/tip-of-the-week-insert-fields/