Mautic Community Forums

SendGrid Intergration timingout

Hi,



I’ve joined sendgrid to manage my outgoing emails from Mautic but when I try to connect using the standard way of selecting sendgrid I get the following error. I have searched for a fix and read 20 different posts with the same issue and the fix of using the other smtp server setting produces the same error. I’ve checked with my hosting and port 587 is not open as I’m not on a VPS but 465 is open for SSL, sendgrid does allow for SSL connection on port 465 so I should have no problem connecting to this via the other smtp server setting… Is this an underlying issue within 2.7? Has anyone else experienced this same issue inside of 2017 as all previous issues relating to connecting to sendgrid that I found were mid 2016 back to 2015 so I don’t know if anything has been resolved with the updates to mautic

Quote:
Connection could not be established with host smtp.sendgrid.net [Connection timed out #110] Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host smtp.sendgrid.net [Connection timed out #110] (code: 0)
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport

Hi,

I’ve joined sendgrid to manage my outgoing emails from Mautic but when I try to connect using the standard way of selecting sendgrid I get the following error. I have searched for a fix and read 20 different posts with the same issue and the fix of using the other smtp server setting produces the same error. I’ve checked with my hosting and port 587 is not open as I’m not on a VPS but 465 is open for SSL, sendgrid does allow for SSL connection on port 465 so I should have no problem connecting to this via the other smtp server setting… Is this an underlying issue within 2.7? Has anyone else experienced this same issue inside of 2017 as all previous issues relating to connecting to sendgrid that I found were mid 2016 back to 2015 so I don’t know if anything has been resolved with the updates to mautic

[quote]
Connection could not be established with host smtp.sendgrid.net [Connection timed out #110] Log data: ++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport !! Connection could not be established with host smtp.sendgrid.net [Connection timed out #110] (code: 0)
++ Starting MauticEmailBundleSwiftmailerTransportSendgridTransport[/quote]

Thank you, I’ve had to purchase a VPS to resolve this