Mautic Community Forums

Site crashes entirely for about 1/2 an hour when i click on configurations in admin

My Mautic version is: 2.15.3
My PHP version is: 7.2.25

My problem is: When I click on “configurations” in the settings section, it hangs, I see the blue “progress” indicator line moving horizontally across the screen and my browser says “waiting for” my domain. At that point, if I try to go to another admin page or a landing page on the site itself, I get a 524 error. After about 1/2 an hour the situation corrects itself and the site loads fine. The situation repeats if I try to go to the configuration page though.

These errors are showing in the log: No errors in the log for that timespan oddly enough

Steps I have tried to fix the problem:
I figured that the fact that it fixes itself in less than an hour means it’s some cron job that does it, so I ran all the cron jobs from the console but that doesn’t speed the process up.

I cleaned up the htaccess file removing all redirects but it had no effect.

What is different about the configuration page? I’ve never seen it so I’ll have to take your word for it.

Is Cloudflare in front of your Mautic instance?

Yes it is! Is this a common problem?

Yes.

Open up the Developer Console and see what errors show up while you’re trying to perform what you did in the Configuration section. Is Mautic non-ssl and you’re using Flexible SSL? If so, I think you have to set up Strict SSL. If you already have Strict SSL setup up, it’s not setup correctly.

1 Like

Thanks so much, I’ll try it out.