Mautic Community Forums

Site is Offline after 2.8.0 Update

I need a little help. While upgrading to 2.8.0 I accidently closed my browser and didn’t let the update complete while it was in the clearing cache step. I tried accessing the site again but I was unable to access anything but the “Site is Offline” page. I’m assuming there’s a way to take it out of “Offline Mode” but I can’t seem to find out how. Or it’s not that simple. I am using Bitnami / AWS. Here are a few lines from the error log:



[2017-04-27 01:55:44] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

[2017-04-27 02:11:07] mautic.WARNING: PHP Warning - require(/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php): failed to open stream: No such file or directory - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

[2017-04-27 02:11:07] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

[2017-04-27 02:11:07] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []



Here are a few lines of the errors in the Apache2 error log:



[Fri Apr 28 01:45:14.838176 2017] [proxy_fcgi:error] [pid 1547:tid 140054252877568] [client 45.37.11.215:52413] AH01071: Got error ‘PHP message: RuntimeException: Unable to create the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 531n’

[Fri Apr 28 01:50:04.373364 2017] [proxy_fcgi:error] [pid 1546:tid 140054244484864] [client 45.37.11.215:53095] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’

[Fri Apr 28 01:53:02.326798 2017] [proxy_fcgi:error] [pid 1546:tid 140054143772416] [client 45.37.11.215:53511] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’

[Fri Apr 28 01:55:40.808376 2017] [proxy_fcgi:error] [pid 1546:tid 140054118594304] [client 173.252.122.120:13572] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’

[Fri Apr 28 02:17:14.359855 2017] [proxy_fcgi:error] [pid 1546:tid 140054269662976] [client 45.37.11.215:57072] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’



I did try replacing the files as well as reset the file permissions based on documented troubleshooting efforts. Any help with getting this back up an running would be greatly appreciated! Thank you!

I need a little help. While upgrading to 2.8.0 I accidently closed my browser and didn’t let the update complete while it was in the clearing cache step. I tried accessing the site again but I was unable to access anything but the “Site is Offline” page. I’m assuming there’s a way to take it out of “Offline Mode” but I can’t seem to find out how. Or it’s not that simple. I am using Bitnami / AWS. Here are a few lines from the error log:

[2017-04-27 01:55:44] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
[2017-04-27 02:11:07] mautic.WARNING: PHP Warning - require(/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php): failed to open stream: No such file or directory - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
[2017-04-27 02:11:07] mautic.ERROR: PHP Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
[2017-04-27 02:11:07] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: require(): Failed opening required ‘/opt/bitnami/apps/mautic/htdocs/app/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/opt/bitnami/php/lib/php:/opt/bitnami/frameworks/smarty/libs’) - in file /opt/bitnami/apps/mautic/htdocs/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []

Here are a few lines of the errors in the Apache2 error log:

[Fri Apr 28 01:45:14.838176 2017] [proxy_fcgi:error] [pid 1547:tid 140054252877568] [client 45.37.11.215:52413] AH01071: Got error ‘PHP message: RuntimeException: Unable to create the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 531n’
[Fri Apr 28 01:50:04.373364 2017] [proxy_fcgi:error] [pid 1546:tid 140054244484864] [client 45.37.11.215:53095] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’
[Fri Apr 28 01:53:02.326798 2017] [proxy_fcgi:error] [pid 1546:tid 140054143772416] [client 45.37.11.215:53511] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’
[Fri Apr 28 01:55:40.808376 2017] [proxy_fcgi:error] [pid 1546:tid 140054118594304] [client 173.252.122.120:13572] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’
[Fri Apr 28 02:17:14.359855 2017] [proxy_fcgi:error] [pid 1546:tid 140054269662976] [client 45.37.11.215:57072] AH01071: Got error ‘PHP message: RuntimeException: Unable to write in the cache directory (/opt/bitnami/apps/mautic/htdocs/app/cache/prod)n - in file /opt/bitnami/apps/mautic/htdocs/app/AppKernel.php - at line 534n’

I did try replacing the files as well as reset the file permissions based on documented troubleshooting efforts. Any help with getting this back up an running would be greatly appreciated! Thank you!

Thank you @MxyzptlkFishStix

Everything except for /htdocs/Upgrade.php is owned by Bitnami. /htdocs/Upgrade.php is owned by root.

What else can I check?

root 1541 0.0 0.3 146448 4048 ? Ss Apr27 0:03 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf
daemon 1546 0.0 1.7 1218692 17316 ? Sl Apr27 0:28 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf
daemon 1547 0.0 1.6 1218856 16828 ? Sl Apr27 0:28 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf
daemon 1787 0.0 1.6 1218676 16628 ? Sl Apr27 0:28 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf
bitnami 18051 0.0 0.0 11740 932 pts/0 S+ 14:56 0:00 grep --color=auto apache

For some reason I get “Operation not permitted” when I try to change the owner.

@MxyzptlkFishStix I wasn’t exactly sure how to elevate to the root user but I was able to find the documentation via Bitnami’s FAQ. I used the following:

sudo su -

Thank you very much for your help. I’m back up and running.

@MxyzptlkFishStix - damned hosted solutions eh!! As to Earl Grey - I approve. It is my tea of choice (although give me a good strong espresso for preference)

Tks! Work for me, clear cache app:

sudo rm -rf /opt/bitnami/apps/mautic/htdocs/app/cache/prod/