Mautic Community Forums

Sugarcrm worked good until upgrading to 2.15

Hi there,

We’d been using sugarcrm w/mautic for a number of years, but after upgrading to 2.15 the integration stopped working. Authentication is working still, but on the fields assignment page all of the fields in Contact Mapping keep reverting back to Address Line 1 and nothing is being sent to SugarCRM ( Version 6.5.16 (Build 1082)).

Anyone run into this, I searched but couldn’t find anything.

Thank you,
Mike

Hi there,

I’m not sure if it’s related, but I found a few posts on the Github repo which relate to SugarCRM:

https://github.com/mautic/mautic/issues?utf8=✓&q=is%3Aissue+is%3Aopen+sugar

Are any of these related to the problem you’re mentioning?

Hi Ruth,

Thank you for the reply. None of those issue seem to be related it seems.

Kind Regards,
Mike

Does anyone have Mautic Community version 2.15 working with SugarCRM community Version 6.5.16 (Build 1082)?

Thanks!
Mike

I tried setting up another plug-in and the same issue exists, so it’s not related to sugarcrm. When I try to assign field in Contact Mapping, after saving the are always reset to Address Line 1.

Hi again,

Do you see any errors in your Mautic error log? What version of Mautic and PHP are you running?

Thanks again for your reply Ruth :slight_smile:

Mautic Community version 2.15/ PHP Version 5.6.25, no relevant errors. Just this one which is a known bug of some nature.

[2019-08-29 11:35:57] mautic.NOTICE: PHP Notice - Array to string conversion - in file C:\inetpub\wwwroot\mautic\app\bundles\CoreBundle\Views\FormTheme\Custom\widget_attributes.html.php - at line 16

I was trying to see if the db needed to be upgraded, but I’m getting an error trying to run the console command:

php console doctrine:migration:status

I’m in the /app directory command window when running the above and getting this seemingly unrelated error.

C:\inetpub\wwwroot\mautic\app>php console doctrine:migration:status
PHP Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in C:\inetp
ub\wwwroot\mautic\app\bundles\EmailBundle\EventListener\ProcessReplySubscriber.p
hp on line 26