The avatar remains broken in Mautic v5.1

The avatar is broken in my freshly installed v5.1, which I installed using Composer. It happened last time, and I fixed it by changing the “site_url”. However, this time it’s not working.

Here are the steps I tried:

  • Removed the index.php from the site_url (local.php file).
  • Added the avatar.png file in the media/images folder, and the permissions are fine.
  • The site URL in the system settings in the Mautic dashboard is the same as the site_url in local.php.


I do have SSL installed properly, and I’m using nginx with proper configs. I’ve double-checked everything. Now the question is, what else should I try to fix it?

Same problem here. Installed with docker + caddy handling the SSL through reverse proxy. All working OK except the avatar.
Image correctly exists and shows in but the app tries to show""%2Fapp%2Fassets%2Fimages%2Favatar.svg%3Fve1459721
and I don’t know why / where can change to fix the http… then if open image in new tab it goes to:
I notice the error “https:/”, maybe this is the cause?