Mautic Community Forums

Avatar: Cannot edit and 404

Just installed Mautic 1.2.4.



The URL for the initial avatar for the admin user (and any other user) is http://i2.wp.com/{MY_SITE_URL}/media/images/avatar.png and obviously gives a 404.



Also I am unable to edit the avatar from the Account Details page. The image is not linkable.



Please advise.

Thanks

The same problem with v2.0.0. Default avatar to http://i2.wp.com/{MY_SITE_URL}/media/images/avatar.png crash.
Default path should be http://{MY_SITE_URL}/media/images/avatar.png

Anyone give a hint to fix this ?

Just installed Mautic 1.2.4.

The URL for the initial avatar for the admin user (and any other user) is http://i2.wp.com/{MY_SITE_URL}/media/images/avatar.png and obviously gives a 404.

Also I am unable to edit the avatar from the Account Details page. The image is not linkable.

Please advise.
Thanks

Hi,

Try to go to your mautic configurations settings. Check your Site URL under General Settings. Make sure your url is like http://your.domainname.com or https://your.domain.com

It worked form me.

I had the exact same problem and just did was @ronald_d suggested (which is remove the /index.php from the site URL).

So the default of Site URL under General Settings of Configuration was:

http://domain.com/index.php

and now it’s:

http://domain.com

I’ll post this solution on git and stackoverflow
https://github.com/mautic/mautic/issues/3382
http://stackoverflow.com/questions/38336645/issue-with-wrong-tracking-urls-in-mautic/42379129#42379129