Mautic Community Forums

Timing interval issues for campaign

Hi there, please refer to my campaign sceenshot: http://take.ms/jXQ1N



Issues encountered:


  1. This is for campaign #1. 3min short-time intervals are used for testing purposes. Problem is from campaign #2 onwards, it doesn’t allow short time intervals, not even hours (for testing). Anyway to work around it?


  2. The 2nd email was only sent the next day even though the time interval is set to 3mins


  3. Encounter random/different email sending timings which don’t follow what was set, and timing also varies for different email providers (e.g, gmail, hotmail, yahoo etc)


  4. Jumps to 2nd email within secs even though the setup rule states 3min waiting interval for ‘non-opening’ of 1st email before it can trigger sending of 2nd email.



    Anyone can share what’s wrong? Appreciate your kind help.

Hi there, please refer to my campaign sceenshot: http://take.ms/jXQ1N

Issues encountered:

  1. This is for campaign #1. 3min short-time intervals are used for testing purposes. Problem is from campaign #2 onwards, it doesn’t allow short time intervals, not even hours (for testing). Anyway to work around it?

  2. The 2nd email was only sent the next day even though the time interval is set to 3mins

  3. Encounter random/different email sending timings which don’t follow what was set, and timing also varies for different email providers (e.g, gmail, hotmail, yahoo etc)

  4. Jumps to 2nd email within secs even though the setup rule states 3min waiting interval for ‘non-opening’ of 1st email before it can trigger sending of 2nd email.

Anyone can share what’s wrong? Appreciate your kind help.

Really urgent to get the campaigns to be setup properly, tested and start running, hence appreciate any help I can get. Thanks a million.

  1. What is campaign #1 and what is campaign #2?
    2), 4) I don’t see any node for sending a second email in your screen shot.
  2. Yes, different providers can use different methods to send emails and it can cause different delivery times. In Mautic, it depends how often your crons are running.

Thanks for the quick reply escopecz, appreciate.

Campaign #2 screenshot is here: http://take.ms/RuKJN

2nd email is sent when leads are placed into lead list ‘email #2 list’, which is the lead source in campaign #2. This whole email drip is sizable hence I break it into different campaigns each tie to an email. Is this the correct way? Thanks for your help.

It can be configured like this. What is your cron interval for each command?

Hi escopecz, our cron interval is 1min. Is this fine? Thanks.

I also tested the campaigns in my free mautic account and face similar issues.

Hmm, so what are we talking about? A self-hosted Mautic or Mautic hosted by mautic.com? You say you’ve tested it on both with similar issues. How similar was it?

I tried both to make sure the problem doesn’t exist in self-hosted mautic only.

Similarities as in having random email sending intervals instead of according to set intervals. Thanks.

Well, I have no idea what’s going on. It works for me as it should.