Mautic Community Forums

"Total Contacts" is not correct - any idea why?

Your software
My Mautic version is: 3.0
My PHP version is: 7.3.24
My Database type and version is: mySQL

Your problem
My problem is: For some reason my “total contacts” shown in the dashboard graph is wrong - I am referring to the dashboard. This is not a “deal-breaker” at all - just curious to know why it doesn’t reflect exactly what is in the DB. “Created Contacts In Time” is the widget - and this is wrong.

Any thoughts?

These errors are showing in the log: none

Steps I have tried to fix the problem: none

Hmm, could that be a cache issue?
I’ve seen it also before, but somehow always healed itself.

Thanks for the help - however - it seems that I found the “reason” (I think).

Contacts are being created from mere visitors to my site. I do NOT have a form yet connected to this site but I do have the WordPress plugin set up.

So, if you toggle the “Anonymous Contacts” button on the contacts page then it shows all these random IP addresses that I assume are from visitors to my site (or bots).

Can we switch this off or is it on purpose to try and later connect real contacts with their visits to my site?

I hope the screenshots help further.

Thanks for all help.

Ah ok…

Yes, it appears that Mautic does indeed create “contacts” for visitors to your site.

Seems a little odd to call them “contacts” though b/c they aren’t.

Anyways - not a deal breaker at all.

I wonder though whether this adds a lot of data overhead to the database over time?

Thanks Joey…I think I found the “issue” or rather inbuilt Mautic behaviour

Hi!
Great. However, I encourage you to use unknown visitors as well.
You can create a focus item, add it to a dynamic content, which you filter for unknown contacts, and you can show popup to them to enter their email.
It is one of the best features of Mautic.
Good luck.
J

That’s a great feature, I’ll try it out