Mautic Community Forums

Unable to Select Images for Mailers from finder

Your software
My Mautic version is: 3.1.0
My PHP version is: PHP 7.2.24-0ubuntu0.18.04.6

Your problem
My problem is:

When I try and create a new email and choose to insert an image from the media browser I am unable to choose any image and insert into the mailer.

These errors are showing in the log:

No errors in mautic.error

Is this is a new installation or an upgrade?

Thanks for the reply @devsrealm. This is an upgrade from 2.16.3

Oh, could you provide a screenshot so we can see what is going, I don’t think this is a bug, but try providing a screenshot of what happened when you tried inserting the image.

ezgif.com-video-to-gif

I am not seeing anything in mautic.errors log or anywhere else

I just noticed in the gif I created, it does not show the finder window where I am selecting an image. but that is basically what is happening. open the finder window, choose an image, select it, and it does not bring it in

Gotcha, could you try opening your browser console to see what error it logs! It might be some conflict, paste the error here if you get any

when I inspect on the builder page, console gives nothing.

then inspect on finder window and get this

That’s where the error is coming from, 404 means the address cannot be found, you can try checking your site URL in the configuration panel if it’s in place, It could also be a be elfinder is missing altogether in your mautic instance.

cd into your mautic directory, and run the following command:

find . -type f -name “elfinder.LANG.js” -exec echo “{}” ;

When I did this, I got the following output:

user@server:/var/www/mautic$ find . -type f -name “elfinder.LANG.js” -exec echo “{}” ;
./vendor/studio-42/elfinder/js/i18n/elfinder.LANG.js
./vendor/components/elfinder/dist/js/i18n/elfinder.LANG.js
./app/bundles/CoreBundle/Assets/js/libraries/filemanager/elfinder/dist/js/i18n/elfinder.LANG.js

If you don’t get this, then it might be an issue when you tried upgrading.

I did this and got the same:

locate elfinder.LANG.js

/app/bundles/CoreBundle/Assets/js/libraries/filemanager/elfinder/dist/js/i18n/elfinder.LANG.js

/vendor/components/elfinder/dist/js/i18n/elfinder.LANG.js

/vendor/studio-42/elfinder/js/i18n/elfinder.LANG.js

Have you checked the folder permission or the mautic folder permission, I doubt that is the issue, but you can also give that a sneak peek. It could as well be a bug.

everything is www-data:www-data

I can drop an image in from my local computer in to the Drag-n-Drop window.

So frustrating… very difficult to troubleshoot

Check out your PM - sent you a message there as well