Mautic Community Forums

Email builder cannot browse for uploaded images

I am using Mautic v2.5.1 and I wanted to edit an email using the Oxygen theme.


  1. I click BUILDER to open up the email
  2. I then click on an existing image in the theme and this opens up the CUSTOMIZE SLOT on the right with the editor activated
  3. I then select an image and then click on the 1st option of the editing options which is to REPLACE the image
  4. Another box opens up and defaults to the 1st option - DROP AN IMAGE (or click to upload an image) - this option works
  5. But I don’t want to upload - I want to browse for an image already uploaded so I click the 3rd option to BROWSE
  6. Another screen opens up but instead of showing me the list of uploaded images, it shows a blank screen with the words NO WAY!



    The path is showing as CURRENT FOLDER / and there is no way to change this path.



    Is there some configuration that I have missed for setting the path to allow the editor to browse for already uploaded images?



    Any help would be most appreciated.



    Cheers,



    Bill


I am using Mautic v2.5.1 and I wanted to edit an email using the Oxygen theme.

  1. I click BUILDER to open up the email
  2. I then click on an existing image in the theme and this opens up the CUSTOMIZE SLOT on the right with the editor activated
  3. I then select an image and then click on the 1st option of the editing options which is to REPLACE the image
  4. Another box opens up and defaults to the 1st option - DROP AN IMAGE (or click to upload an image) - this option works
  5. But I don’t want to upload - I want to browse for an image already uploaded so I click the 3rd option to BROWSE
  6. Another screen opens up but instead of showing me the list of uploaded images, it shows a blank screen with the words NO WAY!

The path is showing as CURRENT FOLDER / and there is no way to change this path.

Is there some configuration that I have missed for setting the path to allow the editor to browse for already uploaded images?

Any help would be most appreciated.

Cheers,

Bill

@MxyzptlkFishStix - Many thanks for the response. All the folders/files that need to be writeable (under Settings > System Info > Folder and File Permissions are highlighted in light green i.e. writeable.

Is there anywhere else I need to check for permissions?

I already did that but still getting the NO WAY message. Isn’t that weird?

My paths for the log and cache are as follows:
/opt/bitnami/apps/mautic/htdocs/app/logs
/opt/bitnami/apps/mautic/htdocs/app/cache

But for images I set it to this:
media/images

All folders/files are writeable - no errors or warning.

What I noticed is that when I try to browse, the URL being accessed was this:

mydomain/app/bundles/CoreBundle/Assets/js/libraries/ckeditor/filemanager/index.html?type=Images

And I was expecting it to be:
mydomain/opt/bitnami/apps/mautic/htdocs/media/images

@MxyzptlkFishStix Please take a look at the screenshots below:

My System Settings:

Asset Settings:

And this is what happens when I try to edit an image in the email.

This is what I get when I try to browse for uploaded images:

And here’s the System Info showing all required folders and files are writeable:

I tried clearing Cache but got an error:

Mautic still running after the above error but the issue remains - “NO WAY” still there. I will check with BITNAMI regarding the error for clearing Cache and see what they say.

Ok I increased the memory limit to 256M and then cleared the cache successfully as shown:

I restarted the server as well and then tried to edit an image in email theme like before.

Still no joy! Still the same problem: “NO WAY”.

But why is the editor browsing to this path:

/app/bundles/CoreBundle/Assets/js/libraries/ckeditor/filemanager/index.html?type=Images

Is that correct???

Ok good news at last!

I didn’t do anything else - just logged out (actually session expired) - and then logged back in and it is all working now :slight_smile:

Thanks for all the help! My faith in Mautic is re-established! :slight_smile: