Mautic Community Forums

Upgrade issue

Hi mate,



I ve got a problem on line 85, dealing with a syntax. Do you know smthg about this?

syntax error, unexpected ‘[’ in upgrade.php on line 85




Did you ever hear about it?



To remind you I’m using 1and1

Hi mate,

I ve got a problem on line 85, dealing with a syntax. Do you know smthg about this?
syntax error, unexpected ‘[’ in upgrade.php on line 85

Did you ever hear about it?

To remind you I’m using 1and1

you are the first person to report a problem with the upgrade script.

Omg! ahahah

https://raw.githubusercontent.com/mautic/mautic/master/upgrade.php

This is the script right?

We just spent 2 hours with my friend to try to understand the errors

And nothing appears.

I remember to put my cron jobs you updated the php version on my 1and1 servor right? How did you do?

[quote=25780:@bunce69]https://raw.githubusercontent.com/mautic/mautic/master/upgrade.php

This is the script right?[/quote]
yes that is the script

[quote=25781:@bunce69]We just spent 2 hours with my friend to try to understand the errors

And nothing appears.

I remember to put my cron jobs you updated the php version on my 1and1 servor right? How did you do?[/quote]
Remember 1and1 support do that since your instance dont let people touch that part of the server.

Ok so what should I do? Contact them?

yes

you also can upgrade using SSH running the upgrade command you dont need to use the upgrade.php if you have access to SSH

Yes I do
how to do?

Actually I changed the script, and then started the SSH command

(uiserver):mautic/upgrade$ /usr/bin/php5.5-cli upgrade.php
Your server does not meet the minimum PHP requirements. Mautic requires PHP version 5.6.19 while your server has 5.5.38. Please contact your host to update your PHP installation.

mautic:update:find Fetches updates for Mautic

mautic:update:apply Updates the Mautic application

Thx for the commands

Do you have the full roots? I had in mautic/upgrade run it and I had “Could not open input file: mautic:update:find”

Now the folder seems to be empty shit

No it’s ok I found it back…anyway if you can just tell me where to load the command
mautic:update:find Fetches updates for Mautic
mautic:update:apply Updates the Mautic application

Then I’ll check again tomorrow

Thank you mate