With Mautic 4 and Composer 2, Composer stalls on this same error with
composer require mautic/api-library --with-all-dependencies,
composer update mautic/core --with-all-dependencies and other commands:
Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires mautic/core-lib ^3.0 → satisfiable by mautic/core-lib[3.x-dev].
- mautic/core-lib 3.x-dev requires willdurand/oauth-server-bundle dev-release-0.0.3 → found willdurand/oauth-server-bundle[dev-master, 0.0.1] but it does not match the constraint.
The response to this bug (?) last February was:
Please ensure that you are using Composer 1 - we will not be supporting Composer 2 until Mautic 4.
We’re now on Mautic 4 and Composer 2. Apparently willdurand/oauth-server-bundle 0.0.3 still does not exist - 0.0.1 does.
Why is willdurand/oauth-server-bundle required for Mautic 4 anyway? It is a ‘Server side implementation of the OAuth 1.0 protocol’ which is not included in Mautic 4 afaik.
What can I edit to skip this requirement and get past this error? I can’t find a mention of willdurand/oauth-server-bundle in the latest composer.json or anywhere in my Mautic installation.