Mautic Community Forums

2.1.1 does not work on shared hosting

I’m using shared hosting and have installed cron jobs properly trough Cpanel

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:segments:update

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:campaigns:rebuild

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:campaigns:trigger

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:webhooks:process

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:emails:send

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:iplookup:download

/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:emails:fetch



This is the only way to make it work to Cpanel and this is something you should have put it in instructions. I do not get any mail that something is wrong as did when when this was not set up properly.

Never the less Campaigns won’t send ( set to immediately) and I noticed that I’m not the only one complaining to this. There isn’t even button to send it manually. But there is a button to send example and this works.

It seem that 2.1.1 version does not work on shared hosting and if this is the case you should tell this to people for them not to waste their time.

I’m using shared hosting and have installed cron jobs properly trough Cpanel
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:segments:update
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:campaigns:rebuild
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:campaigns:trigger
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:webhooks:process
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:emails:send
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:iplookup:download
/usr/local/cpanel/3rdparty/bin/php /home/username/public_html/mautic/app/console mautic:emails:fetch

This is the only way to make it work to Cpanel and this is something you should have put it in instructions. I do not get any mail that something is wrong as did when when this was not set up properly.
Never the less Campaigns won’t send ( set to immediately) and I noticed that I’m not the only one complaining to this. There isn’t even button to send it manually. But there is a button to send example and this works.
It seem that 2.1.1 version does not work on shared hosting and if this is the case you should tell this to people for them not to waste their time.

which version works on hosting?

Actually none I have tried 1.2.3 it does not work either. I’m not sure what is the problem as application install well. Why did you solve the problem of sending with crone job as it is obviously not a good solution as many people on shared hosting can not use the mautic.

I’m starting to wonder is Mautic has a support as many of the same question remain unanswered by any of the staff