API access issues

Your software
My Mautic version is: 4.4.8
My PHP version is: 7.4
My Database type and version is: 10.3.38-MariaDB-0ubuntu0.20.04.1

Your problem
My problem is:
I’ve been using Fluent forms to capture my contacts in Wordpress and transfer them over to Mautic. The problem was that Fluent forms was not able to communicate with Mautic beyond version 4.4.2. Frustrated, I switched over to N8N. N8N was able to load everything fine in 4.4.2, but when I upgraded to 4.4.8, I found that my authentication to Mautic is no longer working. I’m using the same UserID/PW, and even tried creating a new pair, but nothing seems to work.

These errors are showing in the log:
I don’t know if this is significant:
[2023-05-09 06:59:27] mautic.CRITICAL: Uncaught PHP Exception InvalidArgumentException: “The directory “/var/www/mautic/var/cache/prod/jms_serializer” is not writable.” at /var/www/mautic/vendor/jms/metadata/src/Cache/FileCache.php line 49 {“exception”:“[object] (InvalidArgumentException(code: 0): The directory "/var/www/mautic/var/cache/prod/jms_serializer" is not writable. at /var/www/mautic/vendor/jms/metadata/src/Cache/FileCache.php:49)”} {“hostname”:“localhost”,“pid”:211233}
Steps I have tried to fix the problem: Repeated authentication; confirmed ID/pw is valid.


“The directory “/var/www/mautic/var/cache/prod/jms_serializer” is not writable.”

is telling me, that you have permission issues. You need to make sure that all folders and files required by Mautic are writable.


Thank you Joey!!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.