Mautic Community Forums

Asset not downloading

I’m new at this so please be gentle. :-)



I’ve set up an email that I plan to send as a campaign. The email has a link to a page that includes a form. When the form is submitted user is supposed to receive a PDF asset. Pretty typical I think.



it all works except the asset download but maybe I have over complicated things.

I created the email with the link to the page

I created the asset which is my PDF file

I created a signup form with the WP Ninja plugin and a corresponding mautic form (3 fields and a submit button) The mautic form has one action which is to download the PDF asset

I setup the WP Mautic Integrator with the API keys

I linked the 3 fields from the Ninja form to the mautic form

I created a campaign that starts with the contact source of my signup form followed by actions to update the contact; add the contact to a segment; and add points to the contact



When I test using Send Example on the email

Email is delivered as intended

clicking link loads the page with the signup form.

Completing the form and clicking submit clears the page and displays the completion message

the admin receives an email informing of the submission

The contact’s name field is updated if changed from what was stored previously

if I wait for the cron jobs to run I see the 3 campaign actions triggered and the points added



But no asset download occurs.



Is this the right process? Have I over complicated it? Is there an easier way?



What am I missing that keeps the asset from downloading?

I’m new at this so please be gentle. :slight_smile:

I’ve set up an email that I plan to send as a campaign. The email has a link to a page that includes a form. When the form is submitted user is supposed to receive a PDF asset. Pretty typical I think.

it all works except the asset download but maybe I have over complicated things.
I created the email with the link to the page
I created the asset which is my PDF file
I created a signup form with the WP Ninja plugin and a corresponding mautic form (3 fields and a submit button) The mautic form has one action which is to download the PDF asset
I setup the WP Mautic Integrator with the API keys
I linked the 3 fields from the Ninja form to the mautic form
I created a campaign that starts with the contact source of my signup form followed by actions to update the contact; add the contact to a segment; and add points to the contact

When I test using Send Example on the email
Email is delivered as intended
clicking link loads the page with the signup form.
Completing the form and clicking submit clears the page and displays the completion message
the admin receives an email informing of the submission
The contact’s name field is updated if changed from what was stored previously
if I wait for the cron jobs to run I see the 3 campaign actions triggered and the points added

But no asset download occurs.

Is this the right process? Have I over complicated it? Is there an easier way?

What am I missing that keeps the asset from downloading?

@bobyon how did you attached assets ? check my profile for better help it out.

@bizcrony when setting up the form on the actions tab I selected download an asset and selected my PDF

@bobyon I mean is there you can see the PDF in your mautic propperly? CHECK MY PROFILE AND CATCH ME FOR BETTER SOLUTION

Yes, the PDF is visible in the list of assets in mautic

@bobyon need to check my own or can you share that screen shot, I had solved a same problem to my client once

@bobyon, @bizcrony, did you find a solution? I have the same issue, only in a much simpler context. A pop-up Mautic form that should download an asset. It has been working for a couple of years and recently stopped downloading, everything else works: points updated, contact timeline updated, and form data sent via email. But no download.
Self hosted V2.12.1

How may i help you , i need to check

@bizcrony, So I have a form that collects a few fields of contact data and after clicking on “submit”, among other things, downloads an asset for the contact. Everything works except the asset download. Contact info is saved, points are updated, email is sent to me that the form was submitted, but no download of the asset. Same as above with @bobyon. The form is at http://ionsign.fi/iot-big-data/ionsign-gmu491, scroll down and click on Document “GMUX91 Modbus Interface Description”, fill in details and submit. You don’t get the asset :wink:
And this has been working for a couple of years, just recently stopped working.

I submit the form …