Mautic Community Forums

Active won't download

Your software
My Mautic version is: 2.15.2
My PHP version is: 5

Your problem
My problem is:

Why when I set that an active (PDF document) must be downloaded after someone fills out a form, it doesn’t happen anything?
I mean in the form options, not in campaign. The results from that filled form appear properly on the “results” page. Both the form and the active PDF is published.

These errors are showing in the log:

Steps I have tried to fix the problem: Try different actives (documents), check if everything is published

1 Like

Hi @luislago and welcome to the forums! :tada:

Can you check if Mautic thinks that the asset has been downloaded? Do you see it on the contact’s record?

Also, are there any errors on the server log?

Have you tried this on a Mautic landing page, as well as on your own site, if the forum is embedded?

1 Like

Do you see any error in your browser console, and in Mautic logs? (When submiting the form)

1 Like

Mautic does not realise that the asset has been downloaded. It also does not appear on the contact’s record.

Also I have tried the form in a landing page, same result.

My developer says that some property called “content-disposition” on the form structure is missing…

Anyway, I discovered that this only fails with the remote mode, in local mode works well.

When you say remote mode, can you clarify what you mean? If it works locally but doesn’t work in production, that might point to something on your server setup.

Is your form loaded up on a live website somewhere we could look at?

Excuse me.

When I say remote/local, I reference the two available options at the uploading active screen.

One of this forms is now at https://docuten.com/es/docuten_sector_construccion/

Anyway, still trying to figure it out (about this “content-disposition”).

Oh, sorry! So you’re referencing that it works OK if the file is physically located within your Mautic instance, but if you’re linking out to an external resource, it’s not being downloaded?

Could this be something like hotlink protection on the server where you’re hosting the files? I’ve had that catch me out before.

I just checked the form you mentioned and was able to download the PDF file.

Yes, you could because I changed that to the “local” option.