Campaign conditions and actions not executing correctly

Your software
My Mautic version is: 4.1.0
My PHP version is: Not sure, need to ask our dev when they are back from vacation
My Database type and version is: Not sure, need to ask our dev when they are back from vacation

Your problem
My problem is: Campaigns have issues with executing actions and conditions correctly, and also showing already set actions and conditions. It seems to be related to tags, I haven’t had any issues with fields.


  1. Simple conditions are executed the opposite way around. So I’ve set up two branches with condition that if a contact has Tag X, send Email X (Branch 1), and if they don’t have Tag X, send email Y (Branch 2) (For the purpose of clarity for the client I’ve built two branches, rather than using the negative and positive sides of a single condition). And the contact who had Tag X ended up going down Branch 2.

  1. Another condition, if they don’t have Tag Y, re-start the campaign. The Positive branch is left empty. And the contact had Tag Y, and still re-started the campaign.

  1. When I try to open an already set action or condition, the pop-up doesn’t always show but just keeps loading (only with conditions and actions relating to tags so far).

  2. Deleting a set action of re-starting a campaign (“Add to campaign → This Campaign”) didn’t work. The action still stays in view and saving later doesn’t work (it just keeps loading)

These errors are showing in the log: Don’t know, I’d need to ask our dev for that when he comes back in a couple of days

Steps I have tried to fix the problem: Remove the condition and/or action and add it again. It seems to work sometimes for that specific action/condition but then the next action/condition I add can have the same issue.

It doesn’t give an issue for all (tag) conditions and actions, only some of them but I can’t seem to figure out if there is any pattern (only a specific tag etc…)

Hello @theresefub

You can read this info on Settings (on top, right) > System Info

Do you have the same problem with a simple campaign (one condition)?

What is the business use case that requires restarting the same campaign?

Have you tested how the pop-in works in a simple campaign (to isolate this parameter and see where the problem comes from)?

I didn’t understand that point. I think I’m missing some context. :slight_smile:

A good practice in Mautic is to have small campaigns and move from one campaign to another via segments. When you finish a campaign (1 or 2 conditions at most), you send your contact to another segment. Then this segment starts another campaign. This makes it easier to read, debug and maintain.

You access the log in Settings > Sytem Info > Log

I hope this will help you.

1 Like

Thank you @pierre_a !

PHP version: 7.4.29
Database: Maria db 10

I will need to try with a single campaign/condition to see if the same thing happens.

As for the reason for restarting the campaign: We’re waiting for a single change in a custom field that will “trigger” the campaign. Right now I’ve set a wider segment as the source, containing contacts that won’t be eligible and instead re-starting the campaign to keep them going through and catching the ones who’ve had the change.

One way to do it is to create a segment with filters specific for that custom field. That way only the contacts that are eligible will go through the campaign and no re-start is needed. The problem is that I have several campaigns and the number of source segments needed will be around 25, thus cluttering the whole segment section for the client (even if I categorize them). So I wanted to avoid that by the re-start solution.

Hello @theresefub,

If I may suggest that you do all of this it is far too complicated.
If it works with 25 segments then create your 25 segments!
In Mautic the scenario starts well before the scenario screen of the software :wink:


1 Like

I am experiencing a very similar issue.
It appears that conditions in tags are not going down the direct path.

For example: I had ~52k leads in a dynamic segment.
The first condition checks for a valid email.
The positive side of the condition then checks 2 more options (2 different ways if they registered for an event).

  1. If contains a tag (should be false to continue)
  2. Checks a custom field is missing a value (multi-select) (should be true)

The next step is another condition to check if they attended the event last year…
This one separates which email they should receive…

The expected results were the opposite as to what should have happened.
There are only about ~130 people registered currently (either with the tag or custom field).
However, the first condition evaluated to true by 97.6%.

Here is a sample of the campaign

To say that I need to create segments first prior to the campaign like Pierre suggested is a bit ridiculous.

First, segments already take up the majority of my processing time via cron. Second, why have conditions if they can’t run in sequence as they are built out? I should be to chain conditions together in order to direct my leads down the correct path.

So is there something I am missing here?

Hi, can u show the validation setting of your orlando tag?

@joeyk Of course.
Here it is.

Seems legit.
However I tested it and it seems to be working for me:


I’m on 4.2.1 on this install.
Can you plz double check?
Maybe you changed the campaign on the fly?

Thanks @joeyk
I am still on v3. Haven’t had a chance to upgrade to v4. (on aws ec2 and will take some effort)

The problem I am having isn’t with conditions working or not working with tags. It is subsequent conditional checks. It may be different in v4.

As you can see in the original image I posted, it is a conditional followed by another conditional.
The first one is a check on valid email, the second is the tag condition, followed by 2 more conditions.

So the flow goes as follows

  1. Segment
  2. Check valid email
  3. True: Check if has tag
  4. False: check if does not includes event from multi-select custom field
  5. True: Check if includes event from multi-select custom field
    5a. True: send specific email
    5b. False: send specific email

Can you run through that scenario on v4?
If it works, I may need to upgrade sooner than later… haha

Works fine for me.

@joeyk Awesome that it worked. Just not for me… haha

Something has to be going on.

I guess v4 does this process differently? Anything else I could try?

The thing is, it was always working for me, never had an issue even under 3+.
I still think there is some other issue, but I’m not sure. Possible, that you have exactly that one version where there is a bug like that.