Click tracking not working

Assuming you do not have any other proxy in the way…
You have 2 possibilities:

a) Disable all proxying in Cloudflare, which is very simple and straight forward. You can still use their DNS, you only loose the “anonymity” (which is easily circumvented if someone is targeting you anyways).
b) Enable proxy protocol on your Apache, which is kind of complicated and potentially troublesome if you aren’t a seasoned Linux Sys Admin.

In both cases, you do not need to pay unless you want to.

If you happen to be a good SysAdmin or if you are not but feel adventurous, here are 2 good starting points:

PD: Is not really that hard or complex, but the lack of documentation does not help the first time you try to achieve it, after that it’s easy as pie…

Let me know how it goes!

1 Like

Thank you @Yosu_Cadilla for your quick response.

I’ve just set up Mautic on Ubuntu 20.04 with an Nginx web server (instead of Apache) … and after browsing a few Cloudflare links (including one you posted above), I was left with the assumption that I must pay for Cloudflare’s “enterprise” (expensive) package in order to turn on Cloudflare’s “proxy protocol” feature… even if I did manage to set my Apache or Nginx web server to utilize the “proxy protocol”, doesn’t this mean Cloudflare doesn’t include the necessary header information to be deciphered unless they send it (e.g., paying for their “enterprise” feature which can turn on this setting?)

I did see an Nginx document (NGINX Docs | Accepting the PROXY Protocol) specifying how to set up the “proxy protocol” – but again, I’m assuming I’d still need Cloudflare’s “proxy protocol” setting to utilize it?

… unless of course I do not use Cloudflare at all … but I like that they serve my website up faster in various places so am trying my best to find a solution other than just turning off their proxying setting.

I have a fix for this for those that are using Send Grid - or another Email Gateway that uses Link Tracking. It is very important to turn OFF link tracking in Send Grid. It is enabled by default. Once I turned this off - all my links started to track properly :slight_smile: – It was adding something like “url483.” - that is a dead give away if you have something like that. Also a pro tip - When you are experimenting with link tracking for points - Make sure you open up those links in incognito mode - you can not properly test if you open from a browser while you have an active Mautic Session I think it is the cookie that spoils it.