Conditional Campaign Form Not Recording Submission

Your software
My Mautic version is: v4.3.1
My PHP version is: 7.4.30
My Database type and version is: mysqli - 10.5.16-MariaDB

Your problem
My problem is:

I have created a Campaign Form with 5 conditional Selection Options (drop down selection not checkbox). Only three of these options are required. The conditional option is the first required questions. Clients decide what role fits them best then other required fields show up after that selection - required fields being their name and email address.

I then created a campaign for those submissions that send emails depending on the form selection. The campaign source is the Campaign Form previously described. I then added conditions straight from the form for each conditional option (form field is equal to “option”). I want to send specific emails to each conditional option. Example: Selection of “Student” gets sent the Student Email.

The form is being used on our Wordpress site using the Mautic wordpress plugin so that it is attached to a button popup.

These errors are showing in the log:

[2022-07-25 22:29:30] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Routing\Exception\RouteNotFoundException: “Unable to generate a URL for the named route “c” as such route does not exist.” at /home/giantangstrom/public_html/mautic.brainsteering.org/vendor/symfony/routing/Generator/CompiledUrlGenerator.php line 50 {“exception”:“[object] (Symfony\Component\Routing\Exception\RouteNotFoundException(code: 0): Unable to generate a URL for the named route "c" as such route does not exist. at /home/giantangstrom/public_html/mautic.brainsteering.org/vendor/symfony/routing/Generator/CompiledUrlGenerator.php:50)”} {“hostname”:“server1.netex.consulting”,“pid”:2976163}

Steps I have tried to fix the problem:

I have changed the form so that the required fields are stagnant and do not require an answer to fill out information. I’ve disabled the CSS Template option as another post suggested. I’ve tried putting the form on multiple different websites on our Wordpress site.

I believe this may be a server error, however I have no knowledge or understanding of how to read these error messages or what do when they appear. Thank you for your patience.

Hi, is this a shared hosting?
Mautic is known for being unstable on shared hosting, as hosting providers might block vital ingredients for running Mautic

I am not sure, I will have to ask our hosting service provider, thank you for the suggestion