Contact Segment using tag working on compose Mautic instal?

Your software
My PHP version is : 7.4+
My MySQL/MariaDB version is (delete as applicable): MySQL 5

Updating/Installing Errors
I am (delete as applicable): IUpdating
Upgrading/installing via (delete as applicable) : Command Line (compose install)

These errors are showing in the installer : none

These errors are showing in the Mautic log : none

Your problem
My problem is :

I created a contact segment setting tag filter then save it but when I check again, it shows filter as blank again. This was working for me before I reinstalled Mautic using compose but now after reinstalling with compose, it no longer working for me or filter is not adding contacts with the tag I wanted filtered.

Steps I have tried to fix the problem :
Cant figure why filter tag is not being saved.

I recalled that whenever we create a new contact segment then go to the filter tab - after selecting a filter in the dropdown menu, the filter box should appear underneath allowing us to select any available filter correct?

I select tag but no box is appearing underneath the filter selection etc.

Something broke or maybe server missing an extension needed for compose install when I switch Mautic over to compose?


I deleted Mautic and its’ database to try again. We really haven’t started using Mautic was in the process of learning and configuring it to suit our need. But we were getting ready to put it in production until we read the announcement about composer so we decided to start fresh with composer to make it future proof for us.

It’s not looking good at all so far …

Anyway, with the new fresh install, we are still not able to set up the filter on Contact Segment to select any of the filter or “tag” which we wanted to select in the first place.

Is anyone able to select filter for Contact Segement?

Got this one sorted …

The server had shell function restricted so I had to remove the restriction from the shell function since it seems that Mautic needed those shell function to work.

I am having this same problem – when selecting the filter, none of the filter options appear. I just installed Mautic 4.2.0 using bitnami on AWS. All of this is new to me – was on cPanel using Mautic 3x. Couldn’t upgrade because of the database version on the hosting account.

I FINALLY figured out how to get SSH access and tried clearing the cache (again, all new to me, took hours to figure out how to get SSH access. When I tried clearing cache, I didn’t get any error messages, so I think it worked.)

I looked into the solution @techbill used. Can’t see how to do it, but it also sounds “dangerous” if you don’t know what you are doing. Would appreciate any assistance.

The problem came back again with filter for me. I went home for the day.

I am going to troubleshoot it some more tomorrow to see why I am still unable to use filter in segment.

I suspect maybe I am missing some pho extension that composer mautic require to have.

I will update here if I discovered anything

What db and version were you on?

My original install was mySQL 5.6. New Mautic versions require 5.7. Hosting provider could not give me a timeframe for updating. That also was stopping me from updating my PHP to 7.4. (My Mautic version on my hosting account was 3.2.4)… In my original Mautic install, the segment filtering worked as you would expect it to.

I fixed my issue by executing this command

php console mautic:assets:generate

1 Like

I tried the asset regeneration, but am still having the same issue.

Mariadb 10.7
Mautic 4.2.0
PHP 7.4
Ubuntu 20.0.4

Upgrading to 4.2.1 solved this for me