Focus Item Link - Breaking

I am having an issue with Focus Items “Emphasize Link”

When I create this focus item and obviously test from within Mautic everything works fine. However when I am not logged into Mautic the link is breaking.

How do I begin to trouble shoot this ?

I am seeing that when I click on the link it is building a link like this

[type or paste code here](https://my.mautic.com/r/4b364a872b9e3277767dc5529?ct=YToyOntzOjg6ImZvY3VzX2lkIjtpOjUwO3M6NzoiY2hhbm5lbCI7YToxOntzOjU6ImZvY3VzIjtpOjUwO319)

And then taking me to the page “Oh O I think I broke it…”

I tested and this work 100% for me. I also get a similar redirect link as you but clicking the link takes me to the right page. Not much use other than it does not appear to be a Mautic bug but rather something on your set up.

https://mautic.mymautic.com/r/553537cab869ebbc6f133f8e4?ct=YTozOntzOjg6ImZvY3VzX2lkIjtpOjE7czo0OiJsZWFkIjtzOjU6IjE0NTU5IjtzOjc6ImNoYW5uZWwiO2E6MTp7czo1OiJmb2N1cyI7aToxO319&

Links look the same as well.

and just making sure you were not logged in when doing so ?

tested incognito and logged out and it worked fine.

@joeyk do you think this can have anything to do with the multi-domain plugin ?

I don’t think so… but I’ve never tested this scenario.

ok, I also do not think it is this… however I did test on an instance that does not have multi-domain and it worked as @robm mentioned.

I am just thinking what the cause could be, if I am logged in to Mautic the link works, and when I am not, the link gets broken ?

You can remove the multi domain or turn it off temporarly, and see what’s up.

Just checking here, there is no way to turn it off so would it be sufficient for e to move the directory to /tmp , clear cache ? And if I put it back will all my settings still be there ?

Yeah you can remove it, clear cache and all settings should stay in the db

tried that , it is not MultiDomain that is causing the issue :frowning:
Thanks @joeyk

Does anyone have any clue as to why the link would work when you are logged into Mautic and not when you are not logged in ?

I have tried to chown -R www-data:www-data the entire mautic directory.

The pop up is showing, the image is showing, but the link is leading to this internal error broken page.

@rcheesley @ekke ??

A couple of thoughts:

  • Have you checked the error logs to see what the actual error is that’s being thrown? If it is throwing an internal error there should be an associated entry in the error log
  • Is the link going to an asset or a Mautic resource? If so, is it published and publicly accessible outside of the focus item?
  • Can you share the full HTML of the focus item (redact anything that might be sensitive) so that we can see exactly what you have in the focus item?

A post was split to a new topic: Segment section not showing when creating an email

@mikew

Sorry to bump an old post.

I recently came across this issue (version 4.4.3).

The fix is to add target=“_top” at the end of your hyperlink (from within the focus item builder).

I believe target=“_blank” also works.

Hope this helps.

2 Likes

Thanks for this comment @pav03 :slight_smile:

@rcheesley Is this a bug within Mautic?