Help! Activating the Twilio plugin bust things

Your software
My Mautic version is: 4.10
My PHP version is: 7.4
My Database type and version is: mariadb

Your problem
My problem is: I activated the Twilio plugin, loaded my credentials and hit save. The save function got stuck so I had refresh the page. The credentials did save but now I can’t access Mautic configuration, or the plugins page. I can’t access campaigns and I am sure I will discover more issues.

These errors are showing in the log: [2023-11-16 14:33:06] mautic.WARNING: PHP Warning - pack(): Type H: illegal hex digit n - in file /var/www/mautic/app/bundles/CoreBundle/Security/Cryptography/Cipher/Symmetric/OpenSSLCipher.php - at line 41 null {“hostname”:“BetterTimes”,“pid”:3332962}

Steps I have tried to fix the problem: Clearing cache, renaming the twilio file to try deactivate the plugin.

I suspect maybe the phone number that the twilio plugin asked for is the issue. I included a + sign as prefix and perhaps that has caused the issue. Where would I find this value in the data base to edit it?

Hey @robm !

The database table where it’s saved is I believe plugin_integration_settings.

You likely need the Messaging Service ID (SID) which you can get under Messaging > Services on Twilio. We need to write the docs on it so it’s not up to date yet unfortunately.

Hello @robm,

You can switch to Mautic SMSFactor plugin :smiley:


Thanks @rcheesley that confirmed I was looking in the right place.

With the help of chat GPT I quickly became a sql expert :rofl: and deleted the api key and featured_settings values, cleared the cache and solved the issue.

Shew! :face_exhaling:

1 Like

Checked in out but you don’t send SMS to South Africa

All hail ChatGPT eh! :smiley: :bowing_man:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.