Mautic Community Forums

How to get a segment to show in thrive form

I set up a segment (mailing list) for on my form, to use on my wordpress website when making a form.
I click on the “select a mailing list” and there is nothing there to click on.

I am not sure how to fix this. I have tried several times,

Thanks in advance for your help.

John

@John Harder are you using any plugin for this? What mautic version you are talking about ?

Thanks bizcrony for answering, I am still having issues

The mautic version I have is v2.12.1
I have installed a “contacts in mautic” plug in
and “WP Mautic Form Integrator”

@John Harder What about the cron jobs ?

@jharder you setup the API Key for the Thrive plugins to connect with Mautic? without that you will not see anything.

My cron jobs are done and the API key I am not sure. How would I do that?

Connect with service

  1. API CONNECTION
    2. SET CONNECTION DETAILS
  2. SET FORM FIELDS
  3. POST OPT-IN ACTION
    Set Connection Details › Mautic
    Choose your mailing list

This is what comes up in the box when I connect with service.
Choose your mailing list - shows “NO” list. I have 1 list and it doesn’t show.
This is my problem

Thanks all

try to follow this steps
https://www.youtube.com/watch?time_continue=1&v=ZEsoyLV39KI

That didn’t really help my situation. My mailing lists are not showing up once I have clicked on Mautic api to connect it.

Thank you for your help Joan.
My connection is now working.

I have another issue though. I noticed that when I sign up to the form,
it doesn’t send me my first email I have set up.
I just tried manually to send an email to a contact and that isn’t working either:

Failed to send to ebizmh@gmail.com: { “errors”: [ { “message”: “Invalid domain”, “description”: "Unconfigured Sending Domain ", “code”: “7001” } ] }

Is there something incorrect in my settings?
Need help with my sending emails.

This is the message I got when trying to send an email to a members email:

Failed to send to [email address]: { “errors”: [ { “message”: “Invalid domain”, “description”: “Unconfigured Sending Domain “, “code”: “7001” } ] }

I am noticing that the emails are not being sent out through my site: email.dixieclix.com

Hi,

I have the same problem. I don’t see the segments I have in mautic. How did you solve the problem?

Thanks

I contacted Thrive Leads and they went into my account and fixed that problem for me.

:slight_smile: Thanks, that solved the problem and of course, I will tatoo me rule #1. :wink:

Ah yes, clearing the Mautic cache worked for me too.

Thanks for sharing