Mautic Community Forums

Installation on Fasthosts Shared Hosting

Hi,



We have a reseller account with Fasthosts and wanted to try and install Mautic on one of our domains. However after uploading the files when we open the location in our browser we just see a blank page?



Is Fasthosts Shared Hosting not compatible with what you need to install Mautic?



Cheers

Nick

Hi,

We have a reseller account with Fasthosts and wanted to try and install Mautic on one of our domains. However after uploading the files when we open the location in our browser we just see a blank page?

Is Fasthosts Shared Hosting not compatible with what you need to install Mautic?

Cheers
Nick

Hi Nick,

Could you look at your server’s PHP error logs to see what’s recorded?

That was a good shout. It looks as though Symfony is the problem…as in its not installed or available! Any ideas on getting this up and running on the Fasthosts Shared Platform?

here is one of the errors in the log:

…/vendor/symfony/security-bundle/Symfony/Bundle/SecurityBundle/DependencyInjection/Security/Factory/HttpDigestFactory.php): failed to open stream: No such file or directory in /home/hp3-linc2-nfs2-y/076/268076/user/htdocs/inboundmarketing/vendor/composer/ClassLoader.php on line 412

Chers
Nick

Did you install via the package from this site or from github? I wonder if it could be permissions as well. Check to verify the file is actually missing. If it’s not, check the permissions and owner for it to ensure its valid for the host. If it’s missing and you used the package to install, make sure everything uploaded and or extracted.

I downloaded the latest files from here and then extracted and uploaded to the server. I think that it’s a problem the host. I know that Fasthosts seem to bolt things down so I will check with them.

Is there a list of server per-requisites?

Cheers
N