Mautic Community Forums

Installer page is blank

Hi,



I uploaded all the files but the installer page is blank. I’m running the latest Apache 2.2.15, PHP 5.4 and MySQL 5.1.73. Any suggestions?



Thanks!

Hi,

I uploaded all the files but the installer page is blank. I’m running the latest Apache 2.2.15, PHP 5.4 and MySQL 5.1.73. Any suggestions?

Thanks!

I’m assuming you must not have your PHP settings such that it shows any errors.

Hi nateritter,

I checked Apache log and it’s showing this:

PHP Fatal error:  Cannot redeclare class SessionHandlerInterface in /home/igadminsensei/public_html/domain/app/cache/prod/classes.php on line 387

Any idea?

Thanks so much!

OK, I deleted the cache folder inside the app folder and the installer shows up on screen. However, after I clicked “next step” I received the error below.

The CSRF token is invalid. Please try to resubmit the form.

Apache shows this:

mod_fcgid: stderr: #0 /home/domain/public_html/mautic/app/cache/prod/appProdProjectContainer.php(1030): Metadata\Cache\FileCache->__construct('/home/domain...') mod_fcgid: stderr: #1 /home/domain/public_html/mautic/app/bootstrap.php.cache(2071): appProdProjectContainer->getFosRest_SerializerService() mod_fcgid: stderr: #2 /home/domain/public_html/mautic/app/bundles/CoreBundle/Factory/MauticFactory.php(233): Symfony\Component\DependencyInjection\Container->get('jms_serializer') mod_fcgid: stderr: #3 /home/domain/public_html/mautic/app/bundles/CoreBundle/EventListener/CommonSubscriber.php(77): Mautic\CoreBundle\Factory\MauticFactory->getSerializer() mod_fcgid: stderr: #4 /home/domain/public_html/mautic/app/cache/prod/appProdProjectContai in /home/domain/public_html/mautic/vendor/jms/metadata/src/Metadata/Cache/FileCache.php on line 14

Thanks

Are you sure you have the latest release? I haven’t seen that issue, and that would definitely be a code issue.

Hi @j007w

Which files are you using? the beta version downloadable from mautic.org or the master file from github?

On the installer main page (i.e. http://localhost/mautic/installer) do you you see “Ready to Install”?

A few things to check to maybe help us figure out what the issue is.

First, check in app/logs. Do you have any files there? If so, are there any errors written in them?

Make sure that the cache folder is readable and writable by your apache/php user. What that is depends on your apache/php setup.

What browser are you using? I don’t think this is affecting the form submission but you never know. Do you consistently get the csrf token error after a page refresh?

Thanks,
Alan

Hi,

Thank you to everyone who is helping me!

I checked app/logs but it’s empty. The cache folder is readable and writable by Apache/PHP user. I’ve been using Chrome but I just tried Firefox with the exact same results. I do see “Ready to install” in green. When I click “Next Step” I get the CSRF token error.

I was using the beta 1.0 downloaded from mautic.org. However, I found the other version on github so I tried that too with the same results.

Could this have anything to do with Varnish that’s running on the server?

Thanks again!

Varnish could be the issue if it is caching outdated csrf tokens.

You can disable CSRF on the forms by copying app/config/security.php to app/config/security_local.php (it will override security.php and not get overwritten with updates). Then open security_local.php, find and comment out the csrf_provider line

        'main'                 => array(
            'pattern'     => "^/",
            'form_login'  => array(
                //'csrf_provider' => 'form.csrf_provider',

Save, delete app/cache/prod folder and refresh. Can you get through the installer then? If so, then it is a varnish caching issue. You can leave the security_local.php file as it own’t get overwritten by future updates; although you may have to manually update it if the default one ever gets updated.

The disclaimer is that disabling csrf is decreasing security some so do so at your own risk.

Thanks!
Alan

Hi Alan,

It was Varnish! I followed your instructions but still had the same error. Then I accessed the installer via SSL since Varnish can’t cache SSL traffic–and it worked! I was able to finish the installation. I guess it’s better to access via SSL anyway so it’s no big deal. Thanks so much for your help!

Glad that it was an easy workaround :slight_smile:

Thanks!
Alan

I’m having a very similar issue, but the workaround did not work for me.

I just experienced this issue and followed alan’s solution but it didn’t work right away, however I then noticed the Url was:
/Mautic/installer/step/0
I changed the 0 to a 1
and got through to the next step oddly enough.