Mautic Community Forums

IP lookup service still enabled

Hi,



I hope anyone can help me. We have a Mautic instance used on a production website. We had been using the “IP lookup service” and it worked fine, but now we need to turn it off.



We have tried to turn it off from the settings (Configuration -> Miscellaneous Settings-> IP lookup service) and saved the configuration. But when a customer enters a form in the website and the data is sent to Mautic, the location by IP is still retrieved, it’s like the setting is cached or something.



Are settings cached or is there some table with all pre-saved IP addresses that Mautic still uses now?



Many Thanks and hopefully someone can assist.



Stefan

Hi,

I hope anyone can help me. We have a Mautic instance used on a production website. We had been using the “IP lookup service” and it worked fine, but now we need to turn it off.

We have tried to turn it off from the settings (Configuration -> Miscellaneous Settings-> IP lookup service) and saved the configuration. But when a customer enters a form in the website and the data is sent to Mautic, the location by IP is still retrieved, it’s like the setting is cached or something.

Are settings cached or is there some table with all pre-saved IP addresses that Mautic still uses now?

Many Thanks and hopefully someone can assist.

Stefan

Thanks, I will try this!

@sbailey @MxyzptlkFishStix have the solution :slight_smile:

Hi,
the same is happening to me.
Can you tell me how to clean the ip lookup service?

Its probably using the local cached IP location service. If you don’t want it, clear the cache and if there is a cronjob retrieving new GeoIP Data, you may want to disable it.

Deleted cache, but the problem persists… I selected NO Lookup services, deleted the cache…IP are getting geolocated again…

Is that an old contact, which was geolocated before you disabled IP Geolocation?

was an old contact, yes ( is me testing from home), then I deleted it and visited the website again