Mautic Community Forums

Mautic Installation Problem

Hi guys,



I have a problem to set up Mautic on my server. Not sure it’s the best place to ask but i’m almost desperate :) I really need to find a solution.



A month ago, I installed Mautic (v 1.2.2) on my bluehost server without any problem. Everything was working fine and I got the chance to try some of its features. Then, I installed it on another server and deleted the whole program from my first test server. After some days, I saw that I had to set up CRON Jobs to be able to use Mautic (yes, I’m quite a newbie…). It wasn’t possible on my second server (share hosting without access to execute CRON Jobs) and so I decided to install it again on my first server.



Until then, all good but, when trying to install the program (version 1.2.2) now, an error (“Install and enable the fileinfo extension”) pops up right after uploading all the files from FTP. After speaking to my server provider (VPS on bluehost) all day, I still haven’t been able to figure out a solution. I’ve also tried to install the old version (1.1.3). It’s quite some work, but when I want to update to the new one (1.2.2), it downloads the file and stops at “installing updates” (since 4 hours…)



In other forums, some say i have to configure php.ini, others say I should configure .htaccess. I try to set it up from my server (Fileinfo), without any success. If i do phpinfo, it’s say there is Fileinfo.



It’s really strange cause a month ago, everything was working well. I set it up and could start to discover Mautic right away, but now, it seems to be impossible. I know, I’m asking you for rather “server related skills” and not so much about Mautic skills, but if someone has an idea I would really appreciate your help!



Thanks a lot!

Loic

Hi guys,

I have a problem to set up Mautic on my server. Not sure it’s the best place to ask but i’m almost desperate :slight_smile: I really need to find a solution.

A month ago, I installed Mautic (v 1.2.2) on my bluehost server without any problem. Everything was working fine and I got the chance to try some of its features. Then, I installed it on another server and deleted the whole program from my first test server. After some days, I saw that I had to set up CRON Jobs to be able to use Mautic (yes, I’m quite a newbie…). It wasn’t possible on my second server (share hosting without access to execute CRON Jobs) and so I decided to install it again on my first server.

Until then, all good but, when trying to install the program (version 1.2.2) now, an error (“Install and enable the fileinfo extension”) pops up right after uploading all the files from FTP. After speaking to my server provider (VPS on bluehost) all day, I still haven’t been able to figure out a solution. I’ve also tried to install the old version (1.1.3). It’s quite some work, but when I want to update to the new one (1.2.2), it downloads the file and stops at “installing updates” (since 4 hours…)

In other forums, some say i have to configure php.ini, others say I should configure .htaccess. I try to set it up from my server (Fileinfo), without any success. If i do phpinfo, it’s say there is Fileinfo.

It’s really strange cause a month ago, everything was working well. I set it up and could start to discover Mautic right away, but now, it seems to be impossible. I know, I’m asking you for rather “server related skills” and not so much about Mautic skills, but if someone has an idea I would really appreciate your help!

Thanks a lot!
Loic

Hi Loic, that’s quite a long story. Could you tell us also what PHP version do you have?

Hi Escopecz,

After some other hours, I solve the problem :). it was from my host who didn’t activate Fileinfo… But all is good now, thanks for the interest.

Hi, i have a same problem… how to solve?

“We have detected 1 major problems. You must fix them before continuing:
Install and enable the fileinfo extension.”

My version PHP 5.4.35

@d2patrick contact your server administrator / hosting provider and ask him to install and enable the fileinfo PHP extension.

Ok, thanks