Mautic Community Forums

Mautic on Cloudways

Hi,



Has anyone tried to install Mautic on Cloudways with Digital Ocean server or another server?



I need help installing Mautic with Cloudways but their support wasn’t very helpful.



Please point me in the right direction.



Here’s what I tried so far:


  1. Created a PHP Stack application on a Digital Ocean server with Cloudways
  2. Installed Mautic with SSH using step one here: http://freedif.org/mautic-opensource-marketing-email-automation/
  3. Could not follow the rest of the steps in above link

Hi,

Has anyone tried to install Mautic on Cloudways with Digital Ocean server or another server?

I need help installing Mautic with Cloudways but their support wasn’t very helpful.

Please point me in the right direction.

Here’s what I tried so far:

  1. Created a PHP Stack application on a Digital Ocean server with Cloudways
  2. Installed Mautic with SSH using step one here: http://freedif.org/mautic-opensource-marketing-email-automation/
  3. Could not follow the rest of the steps in above link

Hi Adam,

Thank you for the reply. That helped a lot and Mautic is now setup :slight_smile:

Wow so happy to hear that my brief instructions there actually worked.

While these are not completely detailed, here are the steps to follow:

  • Download Mautic zip
  • Create LAMP stack application in Cloudways
  • FTP Mautic to the application folder
  • SSH to application folder to unzip
  • Start the installer process, use the database credentials that Cloudways gives you
  • Configure your crons

Great to know your that your problems is solved by Adam. But few things I need to add in it is that. When you unzip your file on Cloudways, sometimes you will see a permission issue, to solve that go to your application and then to your application settings and click on reset permission there. Also, you need to create a logs folder inside /public_html/app for that log into Putty using Master Credentials, or Cloudways own terminal and create a new directory using it.

P.S. I work at Cloudways

Hey, so i’m running into an error:

PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.

I tried adding always_populate_raw_post_data = -1 to the PHP settings, but it comes back as invalid.

For the time being, I moved to PHP 7.0 instead of 5.6 but it’s not ideal for me right now.

Not sure why you would be getting this error, I had absolutely no issues like this at all.

[quote=15922:@ardit]Hey, so i’m running into an error:

PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.

I tried adding always_populate_raw_post_data = -1 to the PHP settings, but it comes back as invalid.

For the time being, I moved to PHP 7.0 instead of 5.6 but it’s not ideal for me right now.[/quote]