Mautic Recaptcha Bundle plugin

I have installed the Recaptcha plugin and followed all instructions and renamed the directory afterwards, no cache/prod directory , one cache under var/cache but empty no prod directory. I’m running Mautic 3.2.5 and installed the : mautic 3 & 4: [mautic-recaptcha.zip]. When I go in the Mautic dashboard I don’t see the Recaptcha directory even by clicking: Install/upgrade it says 0 plugin installed or updated? Any ideas? Thanks

Hi,
When you say ‘installed’, there are couple of important steps:

  1. download, unzip
  2. make sure the folder’s name in the plugin directory is: MauticRecaptchaBundle
  3. make sure file ownership is right. the files should belong to the same user as your www user (or the rest of the files)
  4. clear mautic cache

Check now.

Hi Joey

Thanks for the reply:

1- Yes downloaded and unzipped
2- Yes I renamed the folder: MauticRecaptchaBundle
3- You mean the file ownership in Windows ( I don’t understand that part) (is it file permission from FTP?)
4- The only cache directory I see it at this path: /var/cache (it’s always empty)

Thanks

Maybe you have a better solution to block spammers or bots from opting in to Mautic forms? I tried using the Configuration section - Form Settings - Do not accept submission from these domain names :
I entered all the .ru domains to block but it still coming in. I also created a Honeypot but it still goes through so not sure if the Recaptcha will work. So that is my last resource to try to block these spammers which I get about 1 opt-in per minute. Thanks

Hi, have you seen this tutorial?

You can change your apache config in a way that a lot of bots can be filtered out.