Mautic Community Forums

Most buttons greyed out on Mautic screens, sometimes error message "That item was not found", no save

Your software
My Mautic version is :l2.15.0
My PHP version is: 7.2.23

Your problem
I logged in and tried to clone a campaign today , made a few changes and decided to save for later. Got the error “This item was not found” it could not be dismissed. Cant reproduce that error now.
shut down and restarteed mautic, tried to create a new campaign: jsut named it and tried to save and close. All the buttons went grey and wold not function, nothing could be saved. I checked and nothing was saved.
Have repeated both these exercises with the same results.

tried to clone a landing page and had the same result. It seems that any attempt to save something results in submit buttons becoming disabled and nothing functioning.
I assume all my campaigns and forms are most likely not functioning either. Im afraid to look at this stage.

These errors are showing in the log:
[2019-10-24 15:05:46] mautic.NOTICE: PHP Notice - date_default_timezone_set(): Timezone ID ‘’ is invalid - in file
Steps I have tried to fix the problem:
I don’t know where to start, not a php or unix person. I checked for plenty of server resources and can see no reason for this behaviour,
I wondered if there was some sort of security tool in Mautic to deal with click jacking that might be misfiring, but do’nt know how to go about it,
Any ideas?

Thanks

Even changing the timezone to Dublin from system default as an experiment has failed to save

Any attempt to save anything now has the same end result

Not sure why I am bothering.
If someone becomes interested or maybe forks this beast, this might help.
The problem is client side.
I went to the office and logged in there when I had a minute. It was working, I was able to finish most f my work.
went home and tried to add a landing page, same problem still exists.
Two PCs in my home office and one in the work office.
All have windows 10 and office 365 using chrome.
Didn’t get around to trying edge, but I do remember failing to save stuff on edge a few months ago when I tried.

Im out of practice with JavaScript 15 years, but I suspect there’s a crummy little library involved somewhere.
Nobody can write JS any more without a huge library of functions to do a tiny job.
I suspect that’s it.
Id this were an active project Id offer to help.
Ill probably create a fork soon. If anyone genuine reads this, get in touch

Thanks for everything

Hi @edward1, I’m sorry to hear that you are disappointed by the lack of a response from the community within an acceptable timeframe.

Please be aware that this is a community-supported project, and as such, people like you who use Mautic are giving their spare time to respond and help others.

While I appreciate it is frustrating when you have a problem and need help from others to resolve it, your tone in the last post is not something we accept in this community.

Please edit your post to remove the profanity, and bear in mind the people who may be reading your request with a view to helping you, and then reading the later posts - they may well be turned away from responding having read those words.

In respect of the problems you have been facing, firstly you are running an outdated version of Mautic, ideally you should be running on 2.15.3 not least due to some security vulnerabilities which were fixed in releases after 2.15.0. At present it is suggested to update via command line, if you need any help with updating or get stuck along the way, this docs page might be useful to you.

In regards to the issue with your instance allowing you to do work at home, and then not at work, I wonder if there is some problem with the browser cache? Have you tried clearing your Chrome cache on the machine that is giving you problems? Do you have the same problems working in an incognito window, or another browser?

In regards to your offer to help, absolutely the project is active, in fact we are holding our first Community Summit on the 1st November which you would be most welcome to join, either in-person or remotely!

We will be working through some bugs and issues in readiness for the next release, improving the documentation, and a team will also be focused on updating the Symfony framework and building out the next version of Mautic. If you have experience with JS I’m sure that there would be tasks you could help us with!

Either way, let us know how you get on with the suggestions above.

Thanks for coming back.
I have been obviously very frustrated by it.
I worked on opensource in the past and really wanted to know of there is no commitment because t is not as simple as " we do it for free so…"
If someone like me is foolish enough to trust my children’s livelihood on a working tool on somebody’s say so, then they have a responsibility. They can always say, “Don’t use this its just a bit of fun and it will break”. Nobody said anything of the kind.

I made a big investment in it and took a huge risk, I am angry with myself for being so foolish and still don’t know if I should just draw a line under all that work and start again with hubspot or something that wont break when i’ve invested 6 months work and 20k of adverts.
If someone wants to work with me and keep things running and do installs for clients, I am interested in talking to them. Last time I tried to get paid help, I had to give up. I found a rude lady in India who was too busy o even answer a polite question and someone who only wanted to do what he wanted to do but not even consider my business requirements. Software doesn’t work that way never has and never will.
In terms of the version I am running, I have a strict policy to wait at least 3 months while all the newly introduced bugs are fixed before risking it. I know that’s not ideal, but what I and every other business needs is something that works even if that is basic, it is better than something that promises to work when the wind is from the right direction.
If I do continue with it I will set up a staging platform when I get a chance and build a set of automated tests in selenium and maybe get the courage to try out new releases then. What I have is full of bugs and adding new features seems crazy while things are failing to save and so forth. I sent two hours on an email and then it failed to save and lost everything, I was tired and used to things that don’t cash and forgot to keep clicking save.
Apologies if any of this sounds like a rant, that is definitely not the intention, but I do think its better to get this stuff in the open and either solve it or walk away.
Regards genuinely,
E

Hi Edward,

Thanks for the response, and I do understand where you are coming from. It is frustrating when things aren’t working and you can’t find the help you need to troubleshoot. In my past professional life running an agency specialised in Mautic I also appreciate the difficulty in finding freelancers who are able to understand your needs and requirements. It can be a big minefield at times!

With that being said, it isn’t an excuse for throwing around profanities. I have edited the post above which I hope is acceptable to you, in order to remove those words, and I hope that in the future we won’t see any repeats.

In terms of finding specialists to help with your Mautic instances, there is the commercial category on this forum where you are welcome to post a request (that category is moderated before posts are shown, to ensure sufficient detail is provided and it’s not a spammy post etc). You can also use the popular job boards like UpWork, for example, where you will find some of our community contributors available for hire.

I hope that you might consider joining us in the community summit next week, that way you will be able to meet (remotely if not in person) with some of the people who have written Mautic, those community members who jump in and help on the forums or fix and test bugs, and maybe you’ll be able to get involved in helping to improve Mautic going forward into the future.

When you open a page on your Mautic install, what’s errors (red) show up in your browser’s dev console (CTRL+I)?

Take screenshots and post them here.

In reply to the kind person offering help.

I am not shocked that today, it behaves normally. I was a developer for 20 years, so I know what to expect.

The problem was only with chrome. In developer mode, then I clicked the button the code for the button flashed an overlay in debugger saying “Disabled” . That’s why I suspected some security tool doing overtime.

To everyone else, I am not going to apologise for losing my patience and using a very mild word that might get your attention, The fact that it did says everything.

I have helped complete strangers regularly since “4 guys form rollei” started doing this online in 1995 with a little forum and still help people with big architecture questions. I don’t think I’m some hero.

When I was stupid I spend time contributing to opensource that went cloud, just like I warned you guys about. The last one was CATS recruitment which closed shop and went cloud. I had contributed loads.
I was poking you with a sharp stick to wake up. Techies are good a t logic and not much use at anything else more often than not. You’d be wise to listen.

If you want something out of Mautic I suggest you create a fork, spend a year fixing bugs and sorting the IA then put it on the cloud and create a steady income. I would have done the IA and written usable guides etc if I saw a reasonable team of people , but apart from angry when I used a word you didn’t like, I wrote requests day after day in slack and never got a single answer apart form one Czech guy who is brilliant but cant be every where.

If there are not enough people even wiling to be involved with Mautic in order to get themselves some work when people like me ask for it, where are you going with this? Who would hang around if they have this sort of experience?
Just out of interest, there is no way I could achieve anything with Mautic if I didn’t know html to sort out emails and landing pages. Those tools are just not up to the job. Some other stuff has real potential.
Id be tempted to write some semantic tools and intelligence to drive sensible personalisation if the basics worked a bit better. The potential is huge, but too much staff half finished and nobody to fix it, nor even sufficient documentation to know what it was trying to do much less how.
Genuinely no bad feeling, just interested in the truth

Ed
By the way, Reply by email doesn’t work