Mautic Community Forums

No Success Notification—System Unsubscribe Page

Hello,

Just launched mautic and loving life so far! This is awesome.

However, an issue has come to my attention involving the default/system Unsubscribe page that comes with the install (RootDomain.com/email/unsubscribe/[user_unique_identifier_code_here].



The problem is the unsubscribe form doesn’t show a Success! or Thanks! message or anything letting the user now it went through.



Is there a way to fix this programatically?

I’ve got alot of emails built, and want to avoid having to make a custom unsubscribe page just to solve the problem, as that would then require me to update the email template, then go back and rebuild all the emails I’ve already made so that the cache busts and the template change takes (best way I’ve found, and it’s a pain).



Any advice or help on making a success message show on the default unsubcribe would be greatly appreciated.

Thanks in advance!

Hello,
Just launched mautic and loving life so far! This is awesome.
However, an issue has come to my attention involving the default/system Unsubscribe page that comes with the install (RootDomain.com/email/unsubscribe/[user_unique_identifier_code_here].

The problem is the unsubscribe form doesn’t show a Success! or Thanks! message or anything letting the user now it went through.

Is there a way to fix this programatically?
I’ve got alot of emails built, and want to avoid having to make a custom unsubscribe page just to solve the problem, as that would then require me to update the email template, then go back and rebuild all the emails I’ve already made so that the cache busts and the template change takes (best way I’ve found, and it’s a pain).

Any advice or help on making a success message show on the default unsubcribe would be greatly appreciated.
Thanks in advance!

You can edit the file (the page) that is display when the user visits the unsubscribe link and you can add a custom text.

Option 2 creates a custom unsubscribe page

Thanks ninjoan.
Only problem is, I don’t see the page in the Landing Page’s list of pages?
I’m fluent in editing files directly if needed, is it located somewhere I can access via sFTP?
Thanks for taking the time!

NOTE: remember is you edit the file when a new version is released this will affect your edit file.