Mautic Community Forums

Custom Unsubscribe Page Does Not Work

Your software
My Mautic version is: 3.3.3
My PHP version is: 7.4

I can’t seem to be able to setup a custom unsubscribe page. It simply doesn’t work according to the instructions outlined on the Mautic documentation here: Customize preference center | Mautic

I’ve triple checked everything and am missing nothing. The unsubscribe link takes you to the default Mautic page with the line " We are sorry to see you go! email@gmail.com will no longer receive emails from us. If this was by mistake, click here to re-subscribe."

These are the steps I have taken…

  • I setup the landing page and selected the “set preference center” for it. The gear icon is showing.
  • Editing the welcome email, I have selected the correct “preference center page” called “Unsubscribe page” under the dropdown.
  • My welcome email has the {unsubscribe_link} token in it.

According to the documentation, this should work, but it does not. Am I missing something?

Many of us have the same issue, it’s a bug that has been reported on github.

1 Like

Did you guys try this? Does the bug still exists?

I followed your TUT a few weeks back and had the bug with 3.3.3 I have not tried recently but as there have not been any updates I expect the ug still exists.

I will try again and report back.

Ok great! I’m glad I’m not going crazy here. Really wish someone would update the documentation to reflect that this feature is not working. Would have saved me a ton of time.

@joeyk yeah it still doesn’t work. Updating the preference center under configuration is the only thing different you did opposed to the documentation, which I tried earlier.

I just tested, and works for me on 3.3.2.
Can you please point me at the github bug, so I can follow the instructions?
image

I think this is it

I think the new builder won’t allow me to create the right preference settings on the page…
So I have to revert to the old builder to test it.
But it seems to be working for me with the old builder, right pref center settings, right language settings.
We could test this together on the next Mautic HelpDesk Meetup, sounds like an interesting task:
https://www.meetup.com/mautic-helpdesk-meetup/

I can confirm that for me it does not work either. I have spent many hours with one of our clients on this and we have bashed our heads and still can’t get it working.

@jensolsson (interesting :wink: )

we were trying on 3.3.3 but I also had tried on 3.3.2.

Thanks for trying bud. It doesn’t work on version 3.3.3, so I can’t really speak for 3.3.2. If you get it working on the 3.3.3 version, please showcase it on a video if you can. I can do the same to show you it doesn’t work.

Quick question: which Landing Page builder do you guys use?

It’s the only one you should be using with this…the Mautic landing pages.

Let me rephrase my question: which landing page BUILDER are you using? The GrapesJs or the legacy builder? Thx.

Again…the Mautic landing page builder inside version 3.3.3.

Why would this entail any other builder? It’s literally stated on the original post and documentation link.

I think the best way to proceed is to assume it’s the legacy builder. I’ll make the screenshots.
Joey

This is 3.3.2, but I don’t see a reason why it should not work on 3.3.3.

Would love to hear what you are doing differently, so we can do an improvement in the email TT :smiley:

Enjoy.

1 Like

Confirmed working with 3.2.4. Still struggling with 3.3.3…

Thanks for checking. I’m eager to find it out. If we can narrow to 3.3.2 → 3.3.3, then we know where to look.