Mautic Community Forums

Wrong Preference Center page on unsubscribe

Your software
My Mautic version is: latest 3.x
My PHP version is: PHP Version 7.4.18
My Database type and version is:

Your problem
My problem is: Wrong Preference Center when clicking on unsubscribe

hi have the same error of this abandoned post

i have a custom landing page set as Preference Center
in the campaign email I have set this page as a Preference Center
but in the emails, when the user click on the unsubscribe link
I get a standard page instead of my custom page

Thanks

Hi @urbanspaceman There have been a number of posts on this topic, one by myself as well Preference Center Not Working.

I did some testing with different versions of Mautic and found that this ‘seems’ to be a bug in certain versions, check out this post and I tried in 3.3.3 and was able to get things working.

1 Like

Thanks Mikew, i’m on 3.3.3 but i have no luck on this…

That is indeed frustrating. Have you defined the preference center inside the email you are sending out ? (I think you said you did this already).

Are you checking in a different browser to where you are logged into your Mautic instance ?

I would also suggest checking out the mautic.error file to see if you are getting any indication on what is going wrong there

yes, each email is set to respond to that particular preference center page

I ran into the same issue, but could solve the problem by changing the settings.

Configuration → E-Mail Settings → Unsubscribe Settings.
Since my mautic installation is using German Language, I’m not sure if I correctly translated the menu items. Therefore I attach the screenshot:

This setting was set to “Nein” (NO/OFF), after switchting to “Ja” (YES/ON), the configured email preference page worked.

Hint: I configured the Segment List on the landing/preference page, but the list wasn’t visible till I activated the setting “Einstellungen für die Segmente anzeigen” (Show Segments Settings).

I’m sorry for the German terms, unfortunatley I don’t know the used english translation, but I think it’s clear what I meant.

Ciao, thanks for the reply
I have the same settings as in your screenshot
but in the end it doesn’t work

Hi,
Quick question: did you try to change language settings for the Email/Preference center?
Joey

Hi @joeyk
I have:
email in English
centerpage in English