Mautic Community Forums

Problem in Connecting my SMTP server

Hello I have a problem connecting my smtp server. I tried testing and sending service like elastic email, other smtp service. It appears error and loads forever/Long. I think my SMTP is broken it can’t connect all servers. Pls help.

Hello I have a problem connecting my smtp server. I tried testing and sending service like elastic email, other smtp service. It appears error and loads forever/Long. I think my SMTP is broken it can’t connect all servers. Pls help.

Can anyone help me to integrate my SMTP service to my mautic ? Thanks the problem i encounter is it loads longer to connect in test and send email.

I’m using elasticemail.com for years, several days ago I switched to Mautic and have problem when connecting and sending test mail too, it keep showing 502 authen error.

I post a support ticket on support.elasticemail.com, they’re good and show me the solution right away. Finally, I got it fixed by using alternative port 587, and my API key as both username and password (type = login) instead of port 25, and my usual username.

You can try switch the port, or use API key as username & pass. Try some combination, it will work :slight_smile: And don’t forget to check your server if they block some ports. And if not work, try to reach out your SMTP provider and let them help.

Hi, Thank you for your reply.I tried to change the port 587, 25, and 2525 but still the problem i encounter is loading longer. How to check if my port is blocked? and what server I should check mautic, webhosting or elastic email. Thanks for your reply :slight_smile:

WOW it worked now! the port is 465. Thank you for helping me out :slight_smile:

It’s great to hear that! What SMTP provider you are using? The quickest way to check if a port is open or not on your server, just type your domain here —> https://mxtoolbox.com/PortScan.aspx