Mautic Community Forums

Submit form stuck at "please wait"

Hey guys, desperate for a fix here. You can see the form here: http://www.austexsprinklers.com/contact



Any ideas?

Hey guys, desperate for a fix here. You can see the form here: http://www.austexsprinklers.com/contact

Any ideas?

Yep! This should be an easy fix. It looks like your Mautic location is not correct. When I viewed your website with the developer console enabled I see that the tracking pixel fails to load. As a result I am betting that your form is not able to submit correctly to your Mautic instance. Check to make sure that’s working and you should be back in business!

Thanks,
David

Thanks for the reply - but nothing had changed and up till the 7th I had 116 form entries…The current URL in the configuration settings is http://www.austexsprinklers.com/mautic

This screenshot shows the tracking pixel is not loading. You may not have intentionally changed something on your site but something on your website is now different (perhaps htaccess?) For whatever reason your website is preventing access to the tracking pixel.

http://drop.dbh.li/image/0x3p361t2r47

I’m a little out of my league here. Here’s what I see in htaccess:

BEGIN W3TC Browser Cache

Header append Vary User-Agent env=!dont-vary AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json # DEFLATE by extension AddOutputFilter DEFLATE js css htm html xml # END W3TC Browser Cache # BEGIN W3TC Page Cache core RewriteEngine On RewriteBase / RewriteCond %{HTTP:Accept-Encoding} gzip RewriteRule .* - [E=W3TC_ENC:_gzip] RewriteCond %{HTTP_COOKIE} w3tc_preview [NC] RewriteRule .* - [E=W3TC_PREVIEW:_preview] RewriteCond %{REQUEST_METHOD} !=POST RewriteCond %{QUERY_STRING} ="" RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC] RewriteCond "%{DOCUMENT_ROOT}/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html%{ENV:W3TC_ENC}" -f RewriteRule .* "/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html%{ENV:W3TC_ENC}" [L] # END W3TC Page Cache core # BEGIN WordPress RewriteEngine On RewriteBase / RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

END WordPress

Redirect 301 /who-we-are/ http://www.austexsprinklers.com/about
Redirect 301 /who-we-are http://www.austexsprinklers.com/about

Redirect 301 /learning-center/learning-center/ http://www.austexsprinklers.com/learning-center
Redirect 301 /learning-center/learning-center http://www.austexsprinklers.com/learning-center

Redirect 301 /learning-center/faq-2/ http://www.austexsprinklers.com/learning-center/faq
Redirect 301 /learning-center/faq-2 http://www.austexsprinklers.com/learning-center/faq

Redirect 301 /learning-center/austin-area-water-conservation/ http://www.austexsprinklers.com/learning-center/water-conservation
Redirect 301 /learning-center/austin-area-water-conservation http://www.austexsprinklers.com/learning-center/water-conservation

Redirect 301 /learning-center/current-austin-rebates/ http://www.austexsprinklers.com/learning-center/rebate-programs
Redirect 301 /learning-center/current-austin-rebates http://www.austexsprinklers.com/learning-center/rebate-programs

Redirect 301 /sprinkler-repair-austin-reviews/ http://www.austexsprinklers.com/about/testimonials
Redirect 301 /sprinkler-repair-austin-reviews http://www.austexsprinklers.com/about/testimonials

Redirect 301 /contact-us/ http://www.austexsprinklers.com/contact
Redirect 301 /contact-us http://www.austexsprinklers.com/contact

Redirect 301 /careers/ http://www.austexsprinklers.com/about/careers
Redirect 301 /careers http://www.austexsprinklers.com/about/careers

Redirect 301 /city-water-restrictions/ http://www.austexsprinklers.com/learning-center/austin-area-water-restrictions
Redirect 301 /city-water-restrictions http://www.austexsprinklers.com/learning-center/austin-area-water-restrictions

Redirect 301 /read-our-testimonials/ http://www.austexsprinklers.com/about/testimonials
Redirect 301 /read-our-testimonials http://www.austexsprinklers.com/about/testimonials

Redirect 301 /learning-center/articles/ http://www.austexsprinklers.com/learning-center
Redirect 301 /learning-center/articles http://www.austexsprinklers.com/learning-center

Redirect 301 /more-reviews/ http://www.austexsprinklers.com/about/testimonials
Redirect 301 /more-reviews http://www.austexsprinklers.com/about/testimonials

I don’t know if this is a coincidence, but the site went down on the 7th due to a mistake in billing - the company had been sold and I’m helping the new owner with some marketing tools. The site went back up after billing was squared away but there hasn’t been a form submission since. Before we were getting at least one a day.

OK I think the tracking gif is working - still stuck though…

OK, fixed it. Yes, the tracking gif did not display, I fixed that with an upgrade to 1.2. What ultimate fixed it was reauthorizing the connection to Zoho - that seemed to be it.

Hi @dbhurley i have now the same problem i get stuck on Please Wait… but if a go in the backend the lead is create i have this problem since i update 1.2.2 today any idea?

here is my website http://www.ninmedia.com/blog/ screen shot
http://www.awesomescreenshot.com/image/820240/c8b1af5ed2be7156b788f1315e4a3a8e

UPDATE
i do a downgrade back to 1.2.0 and i dont have the stuck at please wait…

any idea. also went you going to push the next update

I have a similar situation, i get a problem says : Refused to display ‘http://{mymauticurl.com}/form/submit?formId=1’ in a frame because it set ‘X-Frame-Options’ to ‘SAMEORIGIN’

Any idea?

I found what was happening. Be sure your Mautic Server does not have the X-Frame-Option Enabled in your apache.

Ok for some unknown reason if i use the wordpress mautic shortcode the form shows but does nothing.If i copy and paste manual code from the form then it works.

odd behaviour but hey ho. another step overcome!!