Mautic Community Forums

Website with http and https / 1 Mautic installation

Hi,



Very happy with the possibility to experiment with the powerful Mautic platform. Thanks for this!



I have general content on my website (http://domain-a.nl) in http and forms running in https (https://domain-a.nl). Is it possible to track both http and https? Currently my Mautic installation (running on http://domain-b.com) is tracking the http pages (http://domain-a.nl) successful, for example in campaigns and in contact on page level, but has problems with tracking the https part of the website (https://domain-a.nl); all https pages only generate a http homepage (http://domain-a.nl) hit…:(



Is it possible to track both http and https in one Mautic installation?



Thank you for your reply.

Hi,

Very happy with the possibility to experiment with the powerful Mautic platform. Thanks for this!

I have general content on my website (http://domain-a.nl) in http and forms running in https (https://domain-a.nl). Is it possible to track both http and https? Currently my Mautic installation (running on http://domain-b.com) is tracking the http pages (http://domain-a.nl) successful, for example in campaigns and in contact on page level, but has problems with tracking the https part of the website (https://domain-a.nl); all https pages only generate a http homepage (http://domain-a.nl) hit…:frowning:

Is it possible to track both http and https in one Mautic installation?

Thank you for your reply.

You have a specific reason you run both SSL and non-SSL enabled websites?
We are running all of our websites over SSL and we don’t experience such problems.

Maybe putting all on SSL will solve your problem.

~Chris

Hi Chris,

No specific reason and we have changing it all to https on our backlog. But this item is (perhaps until now:) not on the top of the list. Hoped that there would a simple Mautic or Google Tag Manager fix for which i wouldn’t need the developer who is responsible for our websites.

Peter

Did you try setting mautic domain to https://… (Configuration/General Settings/Mautic Domain)?

Also, make sure your cookie secure settings are right:

Configuration/General Settings/Cookie Settings

Set cookie as secure: No
Set cookie as http only: No

These settings worked for me. And as a public service announcement, I’m not using any personally identifiable information in the cookie itself and it’s unlikely anyone can/would do this with mautic (server side information is not accessible without proper auth). If you are by any chance you should set cookies as secure and this solution won’t work for you.

More info here:
http://stackoverflow.com/questions/2163828/reading-cookies-via-https-that-were-set-using-http

For troubleshooting I’d check the CORS settings and cookie domains.

in version 2.8.2 their is no section called cookie settings i am not able to change my site over to https:// without the cookie settings. i am installing mautic on a new site for a client on my other mautic site i had no issues with https:// because it had the cookie settings from an older version i started with. So what do you do now when you have no section with cookie settings in mautic.