Mautic Community Forums

Can't change api settings to yes

When I try to change api settings to yes and select either save & close or apply get Please wait… and it never updates. If I refresh the page it goes back to no.

When I try to change api settings to yes and select either save & close or apply get Please wait… and it never updates. If I refresh the page it goes back to no.

Hi, try these steps:

  1. Check permission of folder app/cache. Has Mautic (php) permission to write?
  2. Remove app/cache folder to rebuild the cache and try to save config again.
  3. Check app/logs folder and server error log for PHP errors.

@escopecz , I have same issue… How do I config Mautic to write into app/cache? Actually it’s 755.

755 should be OK if the owner isn’t root.

Thank you for that.
I have tried all of the above, the permission is 755, I have removed the cache folder and tried again to no avail, the app/log folder is empty.

So there is only one place to look now. Server’s error log.

Thank you escopecz,
I can’t see anything in the error log that helps me, can you give me an idea of what I should be looking for?
Alice

If there is some line at the last few lines containing the word ERROR, copy-paste it here.

I have looked in the server error log and I can’t find anything there beginning with error, That is assuming I am looking in the correct place. I am looking in errors in cpanel
This is the sort of info that I have in there
2015-09-15 08:17:15.269 [INFO] [108.162.216.34:36089] File not found [/home/xxxxxxxx/public_html/404.shtml]
2015-09-15 08:17:15.269 [INFO] [108.162.216.34:36089] File not found [/home/xxxxxxxx/public_html/image/catalog/wssize/PS61K_size.jpg]
2015-09-15 08:16:38.215 [INFO] [108.162.216.22:57480] File not found [/home/xxxxxxxx/public_html/404.shtml]

Alice

I have found the solution here https://www.mautic.org/community/index.php/664-not-saving-config-settings
I disabled ModSecurity (in cpanel) which allowed me to change the settings then re-enabled it.

@Aliceh , I’ve changed ModSecurity as you said but unsuccessfull on creating email and/or API settings. Did you install Mautic under /public_html/ folder?

Yes i have I have mautic installed in public_html/mautic