Mautic Community Forums

"Please wait..." and nothing happens! Unable to save settings.

“Please wait…” and nothing happens!

Unable to save settings i.e. the buttons “save & close” and “apply” effectively don’t work.

The Chrome inspector says this:

http://www.mydomain.com/e/s/config/edit?mauticUserLastActive=1&mauticLastNotificationId=1

Failed to load resource: the server responded with a status of 403 (Forbidden)



Anyone figured out how to fix this?

(mautic version 1.4.1)



Are any standard ModSecurity settings blocking mautic scripts?

@alanp
I had done a server upgrade including upgrade to PHP 5.6 (from PHP 5.5) and the problem disappeared.
What exactly caused it to disappear, I don’t know.
But it’s saving the settings now.
BTW, the cache folder shouldn’t be empty. After visiting the dashboard page it should normally get filled with some stuff.

@alexb, were you able to resolve this issue? I’m having the exact same 403 symptom when trying to save the configuration with shared hosting on HostGator.

I did a fair amount of research about the error and found many fingers pointing to mod_security. I followed up with HostGator and they claim that when the 403 is generated they aren’t seeing anything triggered for ModSecurity, i.e. no reason to “whitelist” my domain as they aren’t seeing anything being caught.

I have Wordpress installed in the root of my public_html, and installed Mautic under /public_html/marketing/mautic/. HostGator support is trying to blame Wordpress as possibly causing the issue. But these are the same “Linux Administrators” who followed up with me, asking for further instruction on opening the browser’s developer tools to see the 403 error. So to say that my confidence in their technical abilities is lacking is an understatement.

Edit: To add some further information:

  • PHP 5.6
  • folder permissions are 755, files have 644. In frustration I temporarily granted everything in /mautic/ 777 permissions; no change to the error, so I changed the permissions back
  • /cache/ was empty, as this was a new install
  • the Wordpress site in the root of /public_html/ works without issue.

I don’t have access to modify security settings in cpanel, including ModSecurity. I would love if this could be anything other than a security snag, as I would be able to resolve it myself without trying to involve my provider’s support team.

@MxyzptlkFishStix
Thanks for pointing those things out. That’s a much more helpful reply than the previous one.
I’m waiting for my VPS to be upgraded today and will then check if whitelisting the mautic application in ModSecurity solves the problem.

But if you’re running mautic with ModSecurity on, then I suspect that you already have or had some custom rules added.
Correct?

P.S.
Checking just now I see that I had enabled COMODO ModSecurity Apache Rule Set.
So, this isn’t a standard rule set. I was under the impression that I had all standard settings. But this is a third-party rule set provider.
I guess the COMODO rule set is a bit more restrictive than the standard ones.

“Please wait…” and nothing happens!
Unable to save settings i.e. the buttons “save & close” and “apply” effectively don’t work.
The Chrome inspector says this:
http://www.mydomain.com/e/s/config/edit?mauticUserLastActive=1&mauticLastNotificationId=1
Failed to load resource: the server responded with a status of 403 (Forbidden)

Anyone figured out how to fix this?
(mautic version 1.4.1)

Are any standard ModSecurity settings blocking mautic scripts?

@MxyzptlkFishStix
I saw that post. It doesn’t apply to me as I have a VPS and can do anything I want on my server.
But I need to know WHAT exactly needs to be done.

And NO, it’s definitely NOT your host’s fault if you can’t save the settings.
It’s the fault of the mautic developers failing to test the script with a very widely used Web Application Firewall.
So, if you DON’T have this issue with your host, that’s what should make you worried because that means:
Your website is probably unprotected.

In other words, mautic works out of the box if your web hosting environment is unprotected.
But if you have ModSecurity (=most widely used web firewall) enabled in your hosting (and running with standard configuration) you won’t be able to run mautic because you won’t be able to save any settings.

This is what it looks like to me right now.
But I’m eager to be proven wrong.

Sorry for the late reply, but I wanted to post this for anyone else who finds this thread: I switched hosting providers and the problem was instantly resolved. I switched to FastComet hosting and couldn’t be happier - easily installed Mautic through the cPanel software installer.

I would suggest that if you are having this issue, switch hosting providers if you’re able. For the time and effort that I had put into trying to resolve this issue, migrating to a new provider took a fraction of that time.