Custom Audiences (Facebook Ads) – Mautic plugin [FREE]

Hi Everybody!

(There is a (off)topic in ‘general discussion’ about the subject but basically all the relevant information should be here, so I take that here for the further communication. The original was here: Mautic - FB custom audience integration - #13 by ebola)

I’m glad to announce that earlier we forked and embraced the old Custom Audiences Mautic plugin and now we have working versions for both Mautic 3 and Mautic 4.

In short, with the plugin you can automatically synchronise your Mautic segments into Facebook - Custom Audiences. After a short setup you do not need anything more, just use your Mautic and all your active segments will be in FB also to use as custom or as base of lookalike audiences. With it you can easily target to your Mautic customers on FB in multi channel marketing, or also you can get new lookalike customers to your already ones.

Precise and detailed manual for it.

You can download them from their dedicated pages:

Please feel free to use them (literally ‘feel free’ as the plugins are also free :smiley:), and do not hesitate to tell me if you have any problems.

3 Likes

Thanks ebola … trying to configure & test, but getting the following error:

[2022-05-04 15:48:05] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalThrowableError: "Attempted to load class "Api" from namespace "FacebookAds". Did you forget a "use" statement for "Twilio\Rest\Api"?" at /public_html/mautic/plugins/MauticFBAdsCustomAudiencesBundle/Helper/FbAdsApiHelper.php line 42 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Attempted to load class \"Api\" from namespace \"FacebookAds\".\nDid you forget a \"use\" statement for \"Twilio\\Rest\\Api\"? at /public_html/mautic/plugins/MauticFBAdsCustomAudiencesBundle/Helper/FbAdsApiHelper.php:42)"} []

Any clue where to look?

I’ve created the Marketing API app & connected to a business FB account with system user several times and all I get is the same error?

Hi!

It is nice to know that we already have new users of our plugin. Thanks for it!

For your complainment:

It seems you do not have the proper dependency background what we wrote detailed in our documentation. Please read it carefully:

If you think to have the required package, please do regenerate the cache of ‘Composer’.

I hope I could help you.