Mautic Community Forums

Email opening and link tracking not working

Hey everyone



I am testing the tracking from an email sent from Mautic. This email is sent via Contact => One of our known contact => Send Email and I select one of our template. Everything seems to be tracked (open email, page hit). But when I go to Channel => Emails all the stats of the email just sent stay at 0. The good news in incognito window, I am properly tracked except that event. Am I missing something?



I am using Sendgrid, but I logged the path of the link and I can see Sendgrid ==> Mautic ==> site, so surely Mautic knows that I clicked on that link from that email?



I even tested the same scenario and disabled Sendgrid tracking to make sure the only link used is the ones generated by Mautic. But same result as before.



I am using Mautic v2.9.2 & PHP 5.6.30.



Thanks for your help.

Hey everyone

I am testing the tracking from an email sent from Mautic. This email is sent via Contact => One of our known contact => Send Email and I select one of our template. Everything seems to be tracked (open email, page hit). But when I go to Channel => Emails all the stats of the email just sent stay at 0. The good news in incognito window, I am properly tracked except that event. Am I missing something?

I am using Sendgrid, but I logged the path of the link and I can see Sendgrid ==> Mautic ==> site, so surely Mautic knows that I clicked on that link from that email?

I even tested the same scenario and disabled Sendgrid tracking to make sure the only link used is the ones generated by Mautic. But same result as before.

I am using Mautic v2.9.2 & PHP 5.6.30.

Thanks for your help.

+1 on this.

I am also using an email provider to send out emails. I encounter the following:

  1. When the asset is opened via link directly out of the email: the download does not get tracked
  2. When the asset URL (the one from Mautic) is used to access the assed: it gets tracked