Mautic Community Forums

Emails going to spam/junk with cloud-hosted Mautic

I’ve just started testing Mautic to see if it’s something we’d like to switch to. However, all the emails sent from the system (whether it be campaign or not) go straight to the Junk folder… I’m guessing it’s because the emails are sent as me@mail-9-atl.mautic.com on behalf of… even test emails go to Junk.



Is there a way around this. There’s no point in us switching to this system if the emails aren’t received.

I’ve just started testing Mautic to see if it’s something we’d like to switch to. However, all the emails sent from the system (whether it be campaign or not) go straight to the Junk folder… I’m guessing it’s because the emails are sent as me@mail-9-atl.mautic.com on behalf of… even test emails go to Junk.

Is there a way around this. There’s no point in us switching to this system if the emails aren’t received.

Hi @anneline I’m more a Self Hosted user butI have one Mautic Cloud for test and the email is sent by name@mydomain.com

Interesting, I guess mine is using that address because it’s the free test version. Once we upgrade I believe we’ll be able to use our own domain.

Do your cloud emails bypass Junk?

I use the free version :slight_smile:

email me maybe you miss something in the settings jninhilario@gmail.com

Thanks ninjoan. I’ll do that.

Mines doing the same thing… Any suggestions will be AWESOME :slight_smile:

Hi @profitness777 - I fixed it by:

  1. Upgrading to the paid mautic-net version
  2. Getting a free Sendgrid subscription and using that to send with (change it in the email settings)

Do you fix the other problem with your domain? @anneline

@ninjoan - not yet.