Help Needed: Mautic Sending Emails from Wrong Address Despite Correct Configuration

Your software
My Mautic version is: 5.0.1
My PHP version is: 8.1
My Database type and version is: MariaDB 10.5

Your problem
I am trying to configure Mautic to send emails using Amazon SES. I have entered the SMTP settings and verified the email addresses in SES. However, when I try to send a test email, I get the following error: *Expected response code "250" but got code "554", with message "554 Message rejected: Email address is not verified. The following identities failed the check in region EU-WEST-3:*". is well…my personal email address, and the only place I have used it is in my profile under User Management, NOT in Configuration > Email Settings > Mail Send Settings > E-mail address to send mail from. So I have no idea why Mautic is trying to use that email address to send emails.

Steps I have tried to fix the problem:

  1. Verified the email addresses in Amazon SES.
  2. Updated the “From Email” in Mautic to admin@******.com.
  3. Double-checked the SMTP settings (host, port, username, password) in Mautic.

I had this problem. Go and change your user you login with email account to the sending account, and it would send from the right one. Mautic team, whats up with that?

Mautic is signing in using the credentials here but is then saying “Hey AWS, I have an email that I’m sending on behalf of which is an address from”. AWS is rejecting that because, to them, it looks like you’re trying to ‘pretend’ to be gmail.

The fix is, as obtainhigh says, make sure that your admin account is the correct account.

Well, in our situation admin login account and sending email had to be same email to send correctly. Maybe update fixed this? not sure yet.