Mautic Community Forums

Mautic settings for Amazon SES

When sending emails using Amazon SES should i select Amazon or other SMTP?

When sending emails using Amazon SES should i select Amazon or other SMTP?

Read through https://medium.com/@AndreiVoica/how-to-integrate-mautic-with-amazon-ses-7fe066e9131c

But short answer: both will work.

@escopecz thanks for that tutorial!

Haha, I just Googled it. Thank the author.

Hello

I have done the steps until D4 but on testing it comes with the following

Connection could not be established with host email-smtp.eu-west-1.amazonaws.com [Connection refused #111] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host email-smtp.eu-west-1.amazonaws.com [Connection refused #111] (code: 0)
++ Starting Swift_SmtpTransport !! Connection could not be established with host email-smtp.eu-west-1.amazonaws.com [Connection refused #111] (code: 0)

Can you please suggest what seems to be a problem?
Thanks

Newbie, my guess is there is a permission issue or a problem with your credentials.

I think that AWS support is like $35/month… you should buy it one time, and put a ticket in, and they’ll get you ironed out within a day. They have some top notch support :slight_smile: !

@Newbie connection refused indicates, that your server can’t connect to the Amazon smtp server. Maybe a firewall is blocking that outgoing traffic?

I have same problem with the following ERROR. Could anyone can help?

Connection could not be established with host ses-smtp-user.20170809-145955 [php_network_getaddresses: getaddrinfo failed: Name or service not known #0] Log data: ++ Starting Swift_SmtpTransport !! Connection could not be established with host ses-smtp-user.20170809-145955 [php_network_getaddresses: getaddrinfo failed: Name or service not known #0] (code: 0)
++ Starting Swift_SmtpTransport !! Connection could not be established with host ses-smtp-user.20170809-145955 [php_network_getaddresses: getaddrinfo failed: Name or service not known #0] (code: 0)

Hi,
Try changing the port.

To me work 587, try with some of this three: 25, 465 or 587…

Have a good luck.

Ah this issue again…

Call your hosting company and tell them to open port 2587. For some reason, this is one of the few ways to get Amazon SES to work on Mautic with shared hosting.

Personally, I use A2 Hosting and it works perfectly with Mautic + Amazon SES.

I’ve used Bluehost, Host Gator and GoDaddy in the past and they all suck. Check these guys out!

Hi escopecz

If your suggestion that both will work, then, I will remove the instructions I put into configuration in Mautic (Since, I do not want to use the SMTP method). I will use the WPMautic plugin.

Thanks to all that responded. ( sourdoughbread, argentumag30, tachien, MxyzptlkFishStix, wittwerch, wittwerch, caleb.hurd, marzio )

RVG

Hi, if anyone else has this problem in Mautic - this is a simple solution that worked for me.

Instead of choosing Amazon SES in the dropdown of the Email Settings of Mautic just choose “Other SMTP Server”.
The credentials are stored in AWS SES Management Console under “SMTP Settings”.

Example:
Host: paste the url of the selected server (e.g. email-smtp.eu-central-1.amazonaws.com)
SMTP encryption type: TLS
Port: 25 (if that doesn’t work try 465, 587 or 2587)
SMTP Authentication mode: Login