Mautic Community Forums

Not all campaign emails sent after update

After updating Mautic to 2.8.2 I have an issue with some campaign emails not being sent to several contacts.



We suddenly get notifications of some campaign emails not being sent while the majority of them are being sent out according to the dashboard graphs. The emails that aren’t sent for some reason keep appearing in the ‘Upcoming emails’ section of the dashboard.



I only can’t figure out why they aren’t sent as the cron jobs are fine, the email settings are fine and most other campaign emails are being sent.



When I check the details of the contacts who are being struck by this issue I notice that previous campaign emails have been sent. However for some reason they are on hold now.



What could be wrong? Any help is much appreciated.

After updating Mautic to 2.8.2 I have an issue with some campaign emails not being sent to several contacts.

We suddenly get notifications of some campaign emails not being sent while the majority of them are being sent out according to the dashboard graphs. The emails that aren’t sent for some reason keep appearing in the ‘Upcoming emails’ section of the dashboard.

I only can’t figure out why they aren’t sent as the cron jobs are fine, the email settings are fine and most other campaign emails are being sent.

When I check the details of the contacts who are being struck by this issue I notice that previous campaign emails have been sent. However for some reason they are on hold now.

What could be wrong? Any help is much appreciated.

Update: digged a little deeper and found out that these contacts has been subscribed in the past. For some reason we get these notifications now when it’s working as intented, the campaign mail should not be sent to the contact.

However it’s still listed in the ‘Upcoming emails’ section which isn’t correct imo. Not really sure if this is a bug or not. Same for the notification.