Mautic Community Forums

Step 1: Mautic Installation Problem

Step 1: Mautic Installation Problem



Hi



Can you help please?



I am on GoDaddy Shared cPanel hosting operation on php version 5.6.21

While installing 2 major problems have been detected. Please see the screenshot on browser http://goo.gl/QTRdPo

It says: The /home/th…p/public_html/mautic/app/logs directory must be writable. Change the permissions of the /home/thesavorgroup/public_html/mautic/app/logs directory so that the web server can write into it.

PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.



The server itself cannot be restarted, however all processes to my instance can be stopped or killed. The zip module has been enabled. The requested script has been added to your .user.ini file as suggested. I cannot locate an app/logs directory/file to allow/change permissions to allow write access. If you can figure a way to resolve the below requirements in a shared environment I will appreciate it.



Many thanks



Regards

Thanks guys how do you create a log file and .user.ini ?

You can put any arbitrary 3-4 character combination into the “Database Table Prefix” field.
And if it’s a database that’s dedicated to Mautic then you don’t need to enter anything into that field.

Database Charset utf8 is recommended.

Thank you. I put utf8 accordingly.

Can you help please with adding cron jobs?

Since I put mautic folder into “public_html” sub-domain which path I should be implementing in cPanel then?

Thanks

Thank you for the suggestions.

The first issue was completed only after I created “logs” myself as there was no /logs directory or file in /home/thesavorgroup/public_html/mautic/app/
It worked!

Since the hosting is using PHP version 5.6 a .user.ini file was copied from /public_html directory to the public_html/mautic sub directory. Effectively correcting the second issue too.

The above settings allowed me to proceed with mautic installation. Can you please confirm that I am doing the right things so far.


I wonder what content should be inserted in the “Database Table Prefix” field?
Is it “Database Charset” with the content “utf8” or shall I leave this field blank?

Thanks

Better yet, don’t use Godaddy, they SUCK!!

To fix the first error you must login via FTP or cPanel and navigate into this directory:
/public_html/mautic/app/

Then you must click or right-click the logs folder and change permissions to 755 (or 0755) or rwxr-xr-x.
That will enable Mautic to write into the logs directory.

To fix the second error you must change a PHP setting which is done via that php.ini file.
But I suspect that you’ll have to contact the GoDaddy support and ask them to change that setting (because there probably isn’t a way for you to make that change). Simply copy the second error message, open a support ticket with GoDaddy and tell them that you need a PHP setting changed and then paste in that error second error message.

Step 1: Mautic Installation Problem

Hi

Can you help please?

I am on GoDaddy Shared cPanel hosting operation on php version 5.6.21
While installing 2 major problems have been detected. Please see the screenshot on browser http://goo.gl/QTRdPo
It says: The /home/th…p/public_html/mautic/app/logs directory must be writable. Change the permissions of the /home/thesavorgroup/public_html/mautic/app/logs directory so that the web server can write into it.
PHP version 5.6.x requires the PHP configuration directive always_populate_raw_post_data be set to -1. This is handled automatically by the .htaccess file when using Apache and mod_php5, but must be set manually in php.ini for other server configurations. Please add ‘always_populate_raw_post_data = -1’ to your php.ini and restart your web server.

The server itself cannot be restarted, however all processes to my instance can be stopped or killed. The zip module has been enabled. The requested script has been added to your .user.ini file as suggested. I cannot locate an app/logs directory/file to allow/change permissions to allow write access. If you can figure a way to resolve the below requirements in a shared environment I will appreciate it.

Many thanks

Regards

@shaba, for the log file this is what I did:

  1. Connect with filezilla or through your host.
  2. Click on your mautic directory
  3. Then click on the “app” folder
  4. If you don’t have a “logs” folder, then right click and select “create directory” call that directory “logs”

@shaba,

FYI I could not fix the user.ini issue. My only option was to install 1.4.1 and do an update to 2.0.1. Hope that helps.

I’m a Mautic rookie and I can’t even get the installer to start. I’m on a GoDaddy virtual server. I uploaded and extracted the zip file to a Mautic folder under one of my subdomain folders. I then tried www.mydomain.com/mautic but I get a “page not found” message on my site. What am I doing wrong?

@frederico
subdomain folders?
If it’s a subdomain, then the address you need to visit in your browser would look similar to this:
http://subdomain.domain.com
or http://subdomain.domain.com/mautic
With a subdomain you don’t typically have a “www”.

It is www.fredhess.com/mautic. I get a page not found message.

I found the problem. thx

@Adam, what about LiquidWeb?

Do you still feel this way about them Adam? I find there managed WP hosting is good. It’s the shared stuff that I find iffy.

@anythingpixel

I personally use A2 Hosting .

Here’s why:

the support team is excellent and knowledgeable
I can install Mautic using the Softaculous app installer which is available in Cpanel (super easy way to install Mautic and doesn’t require you to download any files)
Turbo shared hosting (which what I am currently using) is super fast
I’ve used Bluehost, Host Gator and GoDaddy in the past and they all suck. Check these guys out!

I use arvixe.com.

Its fine … all the way ,Perfect for mautic