Mautic Community Forums

Please wait solution

The problem ofa form submission hanging at the “Please Wait” has ben around a while now and multiple updates have not fixed the issue. This was fast becoming a deal breaker for me.

For the non techs out there, this is what is going on. As a non techie this is how I figured it out and understood it.

If you have your mautic installation in a sub directory, ie NOT in a sub domain or on a domain, you will have this issue. So solution number 1 is move your mautic to a domain or sub domain.

If you don’t want to do that then you need to edit some code - a simple cut and paste job. After a form submission Mautic tries to double check something that fails because it is looking for something on the domain on which your Mautic is hosted, but because your matic is in a sub folder the check fails and the form hangs. So we need to change the code so Mautic changes how it does this check it wants to do.

Using FTP or your file manager under your cpanel. Browse to public html, then look for the folder your Mautic is in. Then look for the media folder and then look for a file called mautic-form-src.js and another file called mautic-form.js

Open each file so you can edit the code. use control F to search for event.origin
It will be around 623 and line 38 in the other file.

Look for the code if (event.origin !== MauticDomain) return;
Replace it with var MauticDomainWithoutPath = MauticDomain.match(/https?://[^/]*/); if (event.origin != MauticDomainWithoutPath) return;

make sure this added as one line of code.

Do this in both files.

Delete the cache by looking for the cache folder i your main mautic folder and deleting it. Don’t worry it will be recreated when you use mautic.

This should solve the issue. Test in incognito mode in your browser.

You will need to reapply this fix after every Mautic update until it gets fixed by an update.

Hi,

I was experiencing the same issue. My Mautic was stuck on “Please wait” after clicking Save & Close or Apply.

I solved it this way!!!..

I just fresh-installed mautic in a subdomain (no subfolder).

John Franco
http://www.concienciamasiva.com/

@jfranco thanks for sharing your experince so other will get advantage of it who has same problem and same issue.

@RobM Yes , ofcourse it also working … if we have install mautic on sub directory.

Thanks @RobM

Hm, I have installed Mautic in a subdomain, just updated to 2.13.1 and got this issue in a new created form, too.

Earlier created forms are doing fine, threse is not that issue.

Rosco

@Rosco CLEAR CACHE AND UPDATE SCHEMA AND CHECK

Hi bizcrony,
thanks for your response.
I had deleted the cache folder in mautic installation an run mautic again. Same issue.
What do you mean with ´update schema´? Running the upgrade process to 2.13.1 once?

I got the mistake:

Using mautic 2.13.1 in a subdomain with forms containing fields with radio or check-buttons occur a ´please wait´ message after submitting such form.
Forms without these field characteristic are working.

oky cool

The please wait screen problem won’t just go away - I have the solution below:

if (event.origin !== MauticDomain) return;
// Replace the above with these two lines in both files
var MauticDomainWithoutPath = MauticDomain.match(/https?://[^/]*/);
if (event.origin != MauticDomainWithoutPath) return;

I tried this solution on version 2.13.1 it did not work. I tried it on version 2.11.1 it did not work. I have tried all the solution I can find on the internet, nothing seems to remove the please wait screen. Mautic is frustrating!!!

I installed Mautic on a direct domain the please wait screen remains, I have installed on a sub domain, same problem

Do anyone know what the solution is?

Kelly hello , i can understand the problem of your , it might be issue with internal server error, you can right click on that page and inspect and see console. and then talk to your hosting. they will resolve internal server issue.

bizcrony thanks for your response. I actually saw “Failed to load resource: the server responded with a status of 403 (Forbidden)” error on the console

Following bizcrony advise, I contacted my host provider and the issue was resolved. According to them what needed to be done was to modify the ModSec config and edit the default items per page from 30 to 20.

I hope this help someone

so talk to your hosting please.

Failed to load resource: the server responded with a status of 403 (Forbidden)?
Modify the ModSec:

open file .htaccess
paste:
#Disable modSecurity
SecRuleEngine Off

How did you upgrade?

I mean what I asked, How did you upgrade mautic?

AmauticUser Try upgrade.php one more time …

I have a pristine install of Mautic on a cPanel add-on domain (not sub-domain). There are is no other CMS installed on this virtual host.

When I try to save config changes I get the now-infamous “Please wait…” screen of death.

My javascript console reports:

[Error] Failed to load resource: the server responded with a status of 403 () on
https://xxxxxxxxxx.com/s/config/edit?mauticUserLastActive=1&mauticLastNotificationId=
Mautic Version 2.13.1
Apache Version 2.4.33
ModSecurity disabled
PHP Version 7.1.18

In php.ini I have given mautic an insane amount of memory etc in order to try to overcome this problem:

asp_tags = Off
display_errors = On
max_execution_time = 120
max_input_time = 120
max_input_vars = 5000
memory_limit = 2000M
post_max_size = 64M
session.gc_maxlifetime = 14400
session.save_path = "/tmp"
upload_max_filesize = 128M
zlib.output_compression = On

ModSecurity is turned off and my system admin checked httpd.conf and all the include files: SAMEORIGIN is not in any of the files.

Solved!

It turns out the Wordfence security plugin in my Wordpress installation was also protecting that sub-folder.

If anyone is having the same problem, see these links for the fix: